Download it now!
Bug 129330 - Change Arabic diacritics' colours separate from base font colour?
Summary: Change Arabic diacritics' colours separate from base font colour?
Status: RESOLVED DUPLICATE of bug 71956
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-12-11 13:21 UTC by Rasheed
Modified: 2020-05-08 05:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of feature in Microsoft Word options (1.44 KB, image/png)
2019-12-11 13:22 UTC, Rasheed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rasheed 2019-12-11 13:21:00 UTC
Description:
When typing in Arabic, it would be really useful if we were able to change the colours of the diacritics, separate from the base/main letter colour itself - similar to what be done in Microsoft Word's advanced options:

https://community.scripture.software.sil.org/uploads/default/original/1X/0c18d4f80afc2be6779ada07383e017c82b02300.png

File|Options|Advanced > Show Document Content > Diacritics

Thanks.

Actual Results:
feature request

Expected Results:
feature request


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Rasheed 2019-12-11 13:22:21 UTC
Created attachment 156490 [details]
screenshot of feature in Microsoft Word options
Comment 2 Buovjaga 2020-04-27 17:44:03 UTC
Let's ask UX where this should reside in the UI
Comment 3 Heiko Tietze 2020-05-04 09:37:13 UTC
Please add an example text and how it should look like. Probably like shown in https://en.wikipedia.org/wiki/Arabic_diacritics which makes me wonder if the types have to be different.
Comment 4 Rasheed 2020-05-04 11:02:04 UTC
(In reply to Heiko Tietze from comment #3)
> Please add an example text and how it should look like. Probably like shown
> in https://en.wikipedia.org/wiki/Arabic_diacritics which makes me wonder if
> the types have to be different.

No, that's showing the i'jaam dots for differentiating letters. Those are treated as part of the letters nowadays.

The diacritics whose colour some programs allow changing are the Tashkeel (marks used as phonetic guides)especially for vowel sounds.

Examples:

http://www.summitsoft.co.uk/pages/Arabic-Editor-Prem-Sh/pages/En/arabic_writing.htm

http://www.summitsoft.co.uk/pages/APen_Screen_Shoots/pages/High_quality.htm

https://www.youtube.com/watch?v=Pt6eBrWtiXk

https://tex.stackexchange.com/questions/13069/coloring-combining-characters-without-changing-color-of-a-base-character/46240#46240

https://stackoverflow.com/q/46775536
Comment 5 Rasheed 2020-05-04 11:06:46 UTC
Btw, thanks for working on this. 

Also, I'm not a hundred percent sure but diacritics as far as fonts are concerned are probably the same thing or very close to what are called accents for fonts of other languages.
Comment 6 Cor Nouws 2020-05-05 18:08:25 UTC
(In reply to Rasheed from comment #5)
> Btw, thanks for working on this. 
We hope for that :)
 
> Also, I'm not a hundred percent sure but diacritics as far as fonts are
> concerned are probably the same thing or very close to what are called
> accents for fonts of other languages.
Yes, it is!
Comment 7 Heiko Tietze 2020-05-07 14:46:01 UTC
Indesign does the trick per find & replace. Could be one solution when we not only search for a specific format/style but also apply with replace. Has the clear advantage of flexibility. But it's not really convenient and we better have a autocorrect option (localized for Arabic language) that applies a format/style when a certain character/letter combination is entered. And if all fails you may solve the problem with a macro.

=> needDevAdvice for input what's feasible
Comment 8 Khaled Hosny 2020-05-08 00:06:50 UTC
Coloring marks independent of their bases does not work correctly in LibreOffice, see bug 71956.

Fixing this will require refactoring how text color is handled in LibreOffice since right now it is tied to the font, and different color means a different font internally and OpenType text layout does not work across fonts, so positing and other layout features will be broken.
Comment 9 Heiko Tietze 2020-05-08 05:56:00 UTC
Why not make it a duplicate then?

Interesting observation the latin á is entered per acut ´ followed by a. Find and replace for [^uB4] selects the whole letter and changing the font applies to all parts. The same with Alef plus Alef Superscript (U+670) splits the letter into two pieces. Not really what we want ;-)

*** This bug has been marked as a duplicate of bug 71956 ***