Download it now!
Bug 129352 - svgio: ellipse stroke-width lost with transform
Summary: svgio: ellipse stroke-width lost with transform
Status: RESOLVED DUPLICATE of bug 128088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:svg, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2019-12-12 18:43 UTC by sam tygier
Modified: 2019-12-13 13:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test.svg (2.39 KB, image/svg+xml)
2019-12-12 18:43 UTC, sam tygier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sam tygier 2019-12-12 18:43:37 UTC
Created attachment 156522 [details]
test.svg

When importing the attached svg file the stroke-width attribute for the 3rd ellipse is lost.

It seems that the transform attribute plays a role.

I see the issue in 6.2.6.2 though to the 6.4 branch. I don't have the issue in 6.0.7.3. I have not checked between those versions, but at a guess the there was the switch to SVGIO in 6.1.
Comment 1 Xisco Faulí 2019-12-13 13:41:48 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9fa01a8d1137a95af9865a3e47995734c40da6e which is already reported in bug 128088

*** This bug has been marked as a duplicate of bug 128088 ***