Download it now!
Bug 129393 - Calc: cannot format whole row of unprotected cells since LO 6.3
Summary: Calc: cannot format whole row of unprotected cells since LO 6.3
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0 target:6.3.5
Keywords: bibisected, bisected, regression
: 130132 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-13 19:49 UTC by adirt
Modified: 2020-09-25 14:32 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
calc document all is protect (no password needed) exept line 2 (8.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-12-13 19:50 UTC, adirt
Details
wrong behavior calc-6.3.4.2 (2.21 MB, video/mp4)
2019-12-13 19:51 UTC, adirt
Details
right behaviour calc 6.2.8.2 (889.41 KB, video/mp4)
2019-12-13 19:52 UTC, adirt
Details
cellProtection_for_row_2_with_LO_Version6.3.4.2_after_reopening (83.92 KB, image/png)
2019-12-13 21:26 UTC, jokrebel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adirt 2019-12-13 19:49:21 UTC
Description:
after closing calc document, cell protection is not correct protected.

Steps to Reproduce:
1.open calc
2.select all rows and columns
3.rightclick-->Format cells-->Cell protection-->enable locked
4.select the whole line (or row?) 2
5.rightclick-->Format cells-->Cell protection-->disable locked
6.safe (ctrl+s)
7.After that you are able to make a background color for line (row) 2 
up to here it seems to be correct
Do not safe the background color change and close calc after step 6
8. open document again
9. not be able to make a background color for line (row) 2

Actual Results:
in LibreOffice 6.3.4.2 release line 2 is blocked for whole line (for example for background color)



Expected Results:
it should be able to make background color for the whole line 2 also after i open the document in calc again.

LibreOffice 6.2.8.2 works correct.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
not blocked, after closing document
Comment 1 adirt 2019-12-13 19:50:50 UTC
Created attachment 156574 [details]
calc document all is protect (no password needed) exept line 2
Comment 2 adirt 2019-12-13 19:51:45 UTC
Created attachment 156575 [details]
wrong behavior calc-6.3.4.2
Comment 3 adirt 2019-12-13 19:52:48 UTC
Created attachment 156576 [details]
right behaviour calc 6.2.8.2
Comment 4 jokrebel 2019-12-13 20:41:45 UTC
Same results here with:
  
Windows 10 64bit and Libre Office Version 6.3.4 just downloaded from https://de.libreoffice.org/download/download/

and same problem exists with:

Ubuntu Linux 20.04 and Libre Office Version 6.3.3.2

"Cell format" then has for row 2 not nothing or ticks for blocked, but a dash (in the other selectable fields too)
Comment 5 jokrebel 2019-12-13 21:26:40 UTC
Created attachment 156579 [details]
cellProtection_for_row_2_with_LO_Version6.3.4.2_after_reopening

Problem too with Version: 6.3.4.2 at Linux

Shouldn't there 

(see Picture cellProtection_for_row_2_with_LO_Version6.3.4.2_after_reopening)

normaly only "nothing" or "a hook" beeing able

sorry for my bad english
Comment 6 raal 2019-12-17 17:03:38 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin; Could you possibly take a look at this one? Thanks

/bibisect-win32-6.3
9f92d23718acb19aeda0f4b4cfa43cd4d3bad8e5 is the first bad commit
commit 9f92d23718acb19aeda0f4b4cfa43cd4d3bad8e5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat May 18 03:32:15 2019 -0700

    source sha:3c3a371c799d00475deb13b4c3e0a8860c7e4fb3
author	Noel Grandin <noel.grandin@collabora.co.uk>	2019-05-15 15:35:51 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2019-05-18 10:46:12 +0200
commit	3c3a371c799d00475deb13b4c3e0a8860c7e4fb3 (patch)
tree	1ff5fdaa95d21f7cdd4e97257adf170b2c98347c
parent	e7ace9a5fa71bd722e7637285a22715729b620d1 (diff)
tdf#125254 Performance: A spreadsheet opens too slow, part2
Comment 7 Noel Grandin 2020-01-14 14:21:00 UTC
raal, are you sure about this bibisect? I can't see how that commit could cause this.
Comment 8 raal 2020-01-14 16:55:18 UTC
(In reply to Noel Grandin from comment #7)
> raal, are you sure about this bibisect? I can't see how that commit could
> cause this.

Hi Noel,checked again with bibisect-win32-6.3
$ git checkout -f 9f92d23718acb19aeda0f4b4cfa43cd4d3bad8e5
   --> bug is here

$ git checkout HEAD~1
   --> bug is not here

git log 9f92d23718acb19aeda0f4b4cfa43cd4d3bad8e5
commit 9f92d23718acb19aeda0f4b4cfa43cd4d3bad8e5
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat May 18 03:32:15 2019 -0700

    source sha:3c3a371c799d00475deb13b4c3e0a8860c7e4fb3

Looks like bug is in your commit.
Comment 9 Commit Notification 2020-01-15 08:27:01 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bf17db716f4ecaf28c2a0797bf90c9b0731015d6

tdf#129393 Calc: cannot format whole row of unprotected cells

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Noel Grandin 2020-01-15 08:31:45 UTC
thanks raal
Comment 11 Xisco Faulí 2020-01-15 09:28:18 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 69a377c37b234b9b609045dbf40c40e0adc0a0b4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 12 Commit Notification 2020-01-15 10:27:01 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c21b6629a8af2b4d87840fcee8d39b3f77f08c98

tdf#129393 Calc: cannot format whole row of unprotected cells

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-01-15 10:27:14 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/22432848e99fddca20168f7637bbf3c579eea601

tdf#129393 Calc: cannot format whole row of unprotected cells

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2020-01-15 12:46:28 UTC
I've tried to create a UItest for this but the UItest frameworks has problems to deal with errormessages, I don't know how to test it atm
Comment 15 Commit Notification 2020-01-17 17:43:23 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-0":

https://git.libreoffice.org/core/commit/7dab34bc494e5b03537105cff385aa880968d9c8

tdf#129393 Calc: cannot format whole row of unprotected cells

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2020-01-29 14:20:07 UTC
*** Bug 130132 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2020-01-29 16:19:40 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1332a16f42c47f377a29cb53c17704a449235664

tdf#130132, tdf#129393: Add unittest

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.