Bug 129417 - Rename PDF export option from "Full-sheet previews" to something else (and the choice is "Whole sheet export")
Summary: Rename PDF export option from "Full-sheet previews" to something else (and th...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: All All
: medium enhancement
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.5.0 target:6.4.1
Keywords:
Depends on:
Blocks: PDF-Export-Options-Dialog
  Show dependency treegraph
 
Reported: 2019-12-15 18:32 UTC by Roman Kuznetsov
Modified: 2020-01-20 06:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-12-15 18:32:21 UTC
Description:
Rename PDF export option from "Full-sheet previews" to something another.

That option allows create one-page PDF file with all data from current sheet include charts, drawings, images, etc.
But option name is badly for me. Previews sounds like Print preview. I mean users can think that it will be only preview of future PDF without creating it!

I suggest rename that option to something like "Full-sheet export" or "Export all sheet to one-page PDF"...

Steps to Reproduce:
1. Open Calc
2. Select menu File->Export ot PDF
3. Look at "Full-sheet previews" on General tab

Actual Results:
we have a strange option name in PDF export dialog

Expected Results:
we have a good option name in PDF export dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 V Stuart Foote 2019-12-16 02:04:29 UTC
Applicable to dialog in Calc module only... but agree that 'preview' is not the best choice.

+ for 'Full-sheet export', or maybe 'Export entire sheet to one oversize page'
Comment 2 Adolfo Jayme 2019-12-16 15:47:31 UTC
Both of you guys had better ideas for this option’s name than I had…

https://twitter.com/born2bgratis/status/1186333548002893825
Comment 3 Muhammet Kara 2019-12-16 16:00:29 UTC
(In reply to Roman Kuznetsov from comment #0)
> Description:
> Rename PDF export option from "Full-sheet previews" to something another.
> 
> That option allows create one-page PDF file with all data from current sheet
> include charts, drawings, images, etc.

Not only the "current sheet", but all sheets.

> But option name is badly for me. Previews sounds like Print preview. I mean
> users can think that it will be only preview of future PDF without creating
> it!
> 
> I suggest rename that option to something like "Full-sheet export" or
> "Export all sheet to one-page PDF"...
> 
> Steps to Reproduce:
> 1. Open Calc
> 2. Select menu File->Export ot PDF
> 3. Look at "Full-sheet previews" on General tab
> 
> Actual Results:
> we have a strange option name in PDF export dialog
> 
> Expected Results:
> we have a good option name in PDF export dialog
> 
> 
> Reproducible: Always
> 
> 
> User Profile Reset: No
> 
> 
> 
> Additional Info:
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
> CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: Skia/Vulkan; VCL:
> win; 
> Locale: ru-RU (ru_RU); UI-Language: en-US
> Calc: threaded

Also some points to consider:
* This option creates a preview of the whole spreadsheet document as a PDF document.
* And the resulting PDF will have pages with a number equal to the number of the sheets in the document
* The pages of the resulting PDF will probably have different sizes (which match the sizes of the corresponding sheets), and is not suitable for printing, but only for viewing on screen to present a preview of the whole document


(In reply to V Stuart Foote from comment #1)
> Applicable to dialog in Calc module only... but agree that 'preview' is not
> the best choice.
> 
> + for 'Full-sheet export', or maybe 'Export entire sheet to one oversize
> page'

'Full-sheet export' sounds okay. 'Export entire sheet to one oversize page' might be misleading because the resulting PDF pages might also be undersized. (It depends entirely on the content of the corresponding sheet)


(In reply to Adolfo Jayme from comment #2)
> Both of you guys had better ideas for this option’s name than I had…
> 
> https://twitter.com/born2bgratis/status/1186333548002893825

Oh, good to know it was you on Twitter. :)
Comment 4 Heiko Tietze 2019-12-19 07:23:07 UTC
Rimut suggested in the design meeting "Whole sheet export". Personally, I don't see a big advantage in any combination of Full/Whole-sheet preview/export - but also not a disadvantage. So do it.
Comment 5 Commit Notification 2020-01-11 10:17:30 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b711f56b612c408560d2743bca0f01a9109f416f

tdf#129417 Rename "Full-sheet previews" to "Whole sheet export"

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Ming Hua 2020-01-12 01:47:20 UTC
Since this feature is new to 6.4 anyway, is there any plan to backport this to 6-4 branch (getting approval for breaking string freeze first, of course)?

If backported, the majority of users can avoid an additional UI change, and translators and documentation workers can avoid extra work.

Thanks.
Comment 7 Heiko Tietze 2020-01-12 08:16:01 UTC
(In reply to Ming Hua from comment #6)
> Since this feature is new to 6.4 anyway, is there any plan to backport this
> to 6-4 branch (getting approval for breaking string freeze first, of course)?

Wouldn't backport complete new functions. Sooner or later you have to update, and I'd rather work on the reason why users stick with outdated versions.
Comment 8 Ming Hua 2020-01-12 09:52:06 UTC
(In reply to Heiko Tietze from comment #7)
> (In reply to Ming Hua from comment #6)
> > Since this feature is new to 6.4 anyway, is there any plan to backport this
> > to 6-4 branch (getting approval for breaking string freeze first, of course)?
> 
> Wouldn't backport complete new functions. Sooner or later you have to
> update, and I'd rather work on the reason why users stick with outdated
> versions.
What new function are you referring to?  The full-sheet export feature is already in 6.4, this bug and Roman's patch is only about how to label it in an option dialog.  The patch only changes one line in a .ui glade file.
Comment 9 Heiko Tietze 2020-01-12 19:53:14 UTC
(In reply to Ming Hua from comment #8)
> > Wouldn't backport complete new functions. Sooner or later you have to
> > update, and I'd rather work on the reason why users stick with outdated
> > versions.

> What new function are you referring to?  The full-sheet export feature is
> already in 6.4, this bug and Roman's patch is only about how to label it in
> an option dialog.  The patch only changes one line in a .ui glade file.

Okay, if the function has made it into 6.4 it's fine. However, we are long time after string freeze and l10n teams are busy working with localization. We cannot put more on top of this pile.
Comment 10 Ming Hua 2020-01-13 18:42:11 UTC
(In reply to Heiko Tietze from comment #9)
> Okay, if the function has made it into 6.4 it's fine. However, we are long
> time after string freeze and l10n teams are busy working with localization.
> We cannot put more on top of this pile.

Thanks.  Now that UX doesn't have any objections, I'll start asking for approval of breaking the string freeze from l10n people (and see if the documentation people are affected as well).  If they feel this is too much work for little gain, they can always say no and I won't push it.
Comment 11 Commit Notification 2020-01-20 06:04:03 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a86fcb4461cc0e3d309f439247f3efea4c057155

tdf#129417 Rename "Full-sheet previews" to "Whole sheet export"

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.