Download it now!
Bug 129427 - FORMATTING MARKS: Symbols should be formatted
Summary: FORMATTING MARKS: Symbols should be formatted
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.beta1+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Formatting-Mark
  Show dependency treegraph
 
Reported: 2019-12-16 11:26 UTC by DM
Modified: 2020-01-09 10:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Libreoffice Symbols Lacking Styling (3.93 KB, image/png)
2019-12-19 08:49 UTC, DM
Details
Screenshot of Word's Symbols Showing Styling (4.74 KB, image/png)
2019-12-19 08:51 UTC, DM
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DM 2019-12-16 11:26:58 UTC
Description:
Things like spaces, paragraph marks don't show any formatting when formatting marks are shown, which makes for a lot of surprises when typing.
* They should be formatted according to the formatting active at their location.
Word for example does this very usefully.

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 2; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB

Steps to Reproduce:
.

Actual Results:
.

Expected Results:
.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2019-12-19 07:09:40 UTC
DM, perhaps I don't understand your problem. If I change text with formatting marks, formatting is also shown for this marks (italics, size, font, ...). Please specify your problem.
Comment 2 DM 2019-12-19 08:49:26 UTC
Created attachment 156665 [details]
Screenshot of Libreoffice Symbols Lacking Styling
Comment 3 DM 2019-12-19 08:51:24 UTC
Created attachment 156666 [details]
Screenshot of Word's Symbols Showing Styling
Comment 4 Dieter 2019-12-19 09:19:35 UTC
For character color I can confirm it with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Are there any other formattings that don't work for formatting marks? If it's only about colors, we could perhaps treat it as a duplicate of bug 80054.
Comment 5 DM 2019-12-19 09:42:41 UTC
Paragraph marks are not very reliable displaying italics. Some fonts do, some fonts don't. For example make a number of paragraph symbols and set them to Arial or Liberation Sans and then italic, you'll not notice any difference between italic and non-italic; whilst a font like Trebuchet MS shows enormous difference (6.4.0.0.beta1)
Comment 6 DM 2019-12-19 09:51:51 UTC
I think also in selecting an area of text, the highlight should show the characters selected as accentuated (if necessary the inversion) of the selection highlight colour where those characters would not otherwise stand out, and that this should apply to the hidden symbols when they are set to be showing.
Comment 7 V Stuart Foote 2019-12-26 15:16:41 UTC
-1, there is no legitimate reason to style NPC and fields on canvas beyond current treatment of field shading and or color assignment to the NPC.

Doing so would actually detract from current suppressed visual indication of what is distinctly non-printable.

bug 58434 is open to move more NPC out of field shading (<Ctrl>+<F8>) to become controlled as formatting marks (<ctrl>+<F10>), while bug 80054 is open to allow user to customize the color for the formatting marks/NPC

IMHO => WF
Comment 8 DM 2019-12-26 15:43:09 UTC
Perhaps it's down to how one interprets a "Show-Hidden" feature.
For example to me it means to show what's hidden yet there, and the font settings on whitespace are part of what's hidden yet there that is valuable to see. Otherwise, you could reasonably argue there's equally little to no value seeing spaces or paragraph marks either as visible symbols in a word-processor. I would argue though they're all useful to anyone who tracks what's hidden for various reasons, and colour is quite a major one in terms of productivity, as it's irksome to be frequently/constantly taken by surprise by your typing being in an unexpected colour.
Another way of looking at it, is that bold, italics and font-size are already formatting the hidden symbols, and it's just the colour that's omitted...
David
Comment 9 Heiko Tietze 2020-01-06 20:30:09 UTC
Not convincing, I'm with Stuart's comment 7.