Bug 129433 - Multiple clipboard for LibreOffice
Summary: Multiple clipboard for LibreOffice
Status: RESOLVED DUPLICATE of bug 60252
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-16 19:01 UTC by Gerrit Michelsberg
Modified: 2019-12-16 19:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerrit Michelsberg 2019-12-16 19:01:23 UTC
Description:
LibreOffice should get a multi-clipboard (for 10 items) organized as a LIFO-stack. If the user just uses ctrl-v the item last added to the clipboard is inserted. But anotother shortcut with the numbers 1, 2, ... 9, 0 (and a visual clipboard-manager) inserts the last 10 items. And in combination with shift, it just inserts the contents without formatting.

Steps to Reproduce:
Paste multiple items to the clipboard.

Actual Results:
Only the last one is in the clipboard.

Expected Results:
There should be a multi-clipboard that remembers the last 10 items, that can be accessed by shortcuts and a visual clipboard-manager, while the traditional ctrl-v works as expected and inserts the item last added to the clipboard. And in addition with shift, the shortcuts should only insert the contents without formatting.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Buovjaga 2019-12-16 19:08:09 UTC
This is out of scope and will not be implemented. Use the manager of the operating system or develop an extension of your own.

*** This bug has been marked as a duplicate of bug 60252 ***