Bug 129457 - writer pdf text import crash
Summary: writer pdf text import crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Insert-File-Content
  Show dependency treegraph
 
Reported: 2019-12-17 20:20 UTC by paolo_debortoli
Modified: 2020-06-11 08:42 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
example .pdf file (6.51 MB, application/pdf)
2019-12-19 00:13 UTC, paolo_debortoli
Details
crash result window (17.44 KB, image/png)
2019-12-19 00:14 UTC, paolo_debortoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paolo_debortoli 2019-12-17 20:20:19 UTC
Description:
I created a .odt document.  I wanted to insert a different .pdf document.  then I selected from menu   insert -> text from file -> pdf.  I selected the file and writer crashed and closed with an error.

Steps to Reproduce:
1.  create / open a .odt  document
2.  select from menu   insert -> text from file -> choose a pdf doc in the window
3.  click   'open'

Actual Results:
writer crashes and closes with an error.

Expected Results:
the pdf  document should be inserted into the .odt  document.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Dieter 2019-12-17 21:18:33 UTC
Paolo, does it happen with every PDF document or with a specific document. If it only happens with a specific document please attach it here, if possible.

=> Status NEEDINFO
Comment 2 m.a.riosv 2019-12-17 21:24:54 UTC
Sorry but writer can't insert text from a pdf file, you can insert a pdf as OLE object through Menu/Insert/Object/OLE Object.

In fact you can't see the pdf on the file types in the Menu/Insert/Text from file.

In any case for me doesn't crash, only show an error message.
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc:
Comment 3 Dieter 2019-12-18 07:06:56 UTC
(In reply to m.a.riosv from comment #2)
> Sorry but writer can't insert text from a pdf file, you can insert a pdf as
> OLE object through Menu/Insert/Object/OLE Object.

Yes, that's right, but question remains, why it crashes and if it happens with every pdf-document.

 
> In fact you can't see the pdf on the file types in the Menu/Insert/Text from
> file.

All files are shown by default. Would be better, if you can see only text files by default.

> In any case for me doesn't crash, only show an error message.

Yes
Comment 4 m.a.riosv 2019-12-18 10:59:28 UTC
(In reply to Dieter Praas from comment #3)
> (In reply to m.a.riosv from comment #2)
> > Sorry but writer can't insert text from a pdf file, you can insert a pdf as
> > OLE object through Menu/Insert/Object/OLE Object.
> 
> Yes, that's right, but question remains, why it crashes and if it happens
> with every pdf-document.
I don't know for me don't crash.

> > In fact you can't see the pdf on the file types in the Menu/Insert/Text from
> > file.
> 
> All files are shown by default. Would be better, if you can see only text
> files by default.
Who knows what are text files by extension, some are common but every one sets the extension that likes, when are not created by an usual program, in any case a request for enhancement not a bug, and sorry but I thing we have enough without corner cases.
 
> > In any case for me doesn't crash, only show an error message.
> 
> Yes
What that means?, crash or only error message, if the last, it's not a bug.
Comment 5 Dieter 2019-12-18 11:26:44 UTC
(In reply to m.a.riosv from comment #4)
> What that means?, crash or only error message, if the last, it's not a bug.

I recieve an error message, but perhaps it crashes at Paolo. So we need that information and perhaps link to crash report.
Comment 6 MM 2019-12-18 16:46:28 UTC
Unconfirmed on mint19.2 x64 with Version: 6.3.0.0.alpha1+
Build ID: 77ae0abe21f672cf4b7d2e069f1d40d20edc49a7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-05-31_15:33:33
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Confirmed with Version: 6.4.0.0.alpha1+
Build ID: 3208236305f7c24fce556fda10eeb9905779a37c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-01_00:32:11
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

V6.3 gives the read error warning and v6.4/6.5 crashes.
Comment 7 paolo_debortoli 2019-12-19 00:13:20 UTC
Created attachment 156660 [details]
example .pdf file
Comment 8 paolo_debortoli 2019-12-19 00:14:34 UTC
Created attachment 156661 [details]
crash result window
Comment 9 paolo_debortoli 2019-12-19 00:20:08 UTC
I have the same result with every .pdf file.

when I try to connect .pdf as a ole object, the software blocks and the only one solution is forcing close the window.

when I try to insert text from .txt document, it doesn't do anything at all.
Comment 10 Xisco Faulí 2020-02-26 17:11:47 UTC
I can't reproduce it in

Version: 7.0.0.0.alpha0+
Build ID: c8d764b3f27c2bb0712745891b70630e94436317
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

and I fail to understand why this issue was changed to NEW. the confirmer didn't leave any comment.
Putting it back to UNCONFIRMED until someone else reproduces it
Comment 11 Terrence Enger 2020-02-26 17:46:47 UTC
On 2019-12-19, I too failed to reproduce the problem.  My note to
myself at the time is a brusque "PLAN: NFA"; I do not remember how
hard I tried.

I believe that it is comment 6 which explains advancing the bug to
status NEW.
Comment 12 Dieter 2020-03-03 07:09:14 UTC
(In reply to Terrence Enger from comment #11)
> I believe that it is comment 6 which explains advancing the bug to
> status NEW.

=> NEW, because of comment 6. Xisco please explain, if you don't agree with it.
Comment 13 raal 2020-03-13 20:42:53 UTC
No crash with Version: 7.0.0.0.alpha0+
Build ID: a11c10a83f6fceae6cfb519725d06f8eaf1013fb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Comment 14 Aron Budea 2020-03-21 04:26:54 UTC
Paolo, are you using LO provided by your distro? (and if so, which one) I wonder if this could be a case of some missing package.

On a sidenote, opening the PDF directly hangs LO.
Comment 15 Buovjaga 2020-06-08 19:32:24 UTC
(In reply to paolo_debortoli from comment #7)
> Created attachment 156660 [details]
> example .pdf file

insert -> text from file does not crash for me. It only gives read error.

MM: can you re-test?

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 2bccbd2ba6c90d5e02285629c2b079c35260c08b
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 3 June 2020
Comment 16 Xisco Faulí 2020-06-09 11:44:09 UTC
Setting to NEEDINFO until Paolo replies to comment 14 or MM replies to comment 15
Comment 17 MM 2020-06-09 17:54:57 UTC
On mint 19.3 with Version: 7.1.0.0.alpha0+
Build ID: 6096d67aa67b0eb3da5e9ad9ae1eaa04baa5102c
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-06-04_05:27:02
Calc: threaded

it doesn't crash anymore, but gives the 'read error' instead.
Comment 18 Buovjaga 2020-06-09 17:59:00 UTC
Great, then let's close.
Comment 19 paolo_debortoli 2020-06-11 08:42:34 UTC
hi.  my libreoffice version is:  

Versione: 6.4.3.2
Build ID: 1:6.4.3-0ubuntu0.20.04.1
Thread CPU: 4; SO: Linux 5.4; Resa interfaccia: predefinito; VCL: gtk3; 
Versione locale: it-IT (it_IT.UTF-8); Lingua interfaccia: it-IT

this time software doesn't crash.

I updated it after installing ubuntu 20.04.


I have always the same problem (ext4 file system):

I opened writer and created a text doc with only one word  (eg abracadabra):
I saved the file as pdf on the desktop;
then I created a new text doc and choosed  insert -> text from file -> <mydoc>.pdf;

writer returned an error:  'error opening file'.

error  can be in the menu options  or file format or I don't know. may be it should work or not have the option (like showing only odt or text files).(In reply to Aron Budea from comment #14)


> Paolo, are you using LO provided by your distro? (and if so, which one) I
> wonder if this could be a case of some missing package.
> 
> On a sidenote, opening the PDF directly hangs LO.