Download it now!
Bug 129468 - UI-Writer: Add 'insert reminder' icon as possibility to add to a toolbar
Summary: UI-Writer: Add 'insert reminder' icon as possibility to add to a toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.5.0
Keywords: needsUXEval
Depends on: 130204
Blocks: UNO-Command-New
  Show dependency treegraph
 
Reported: 2019-12-18 12:21 UTC by sdc.blanco
Modified: 2020-03-29 16:29 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2019-12-18 12:21:47 UTC
Tools > Customize, choose Menu (and Toolbar) tab, Search on "reminder"  (result:  not found)

There is a paperclip icon in Navigator.  It would be practical to have this icon in Customize (e.g., to add to the Find Toolbar) -- where "Navigate by" give the possibility to search for reminders.  (but reminders can only be set right now through Navigator.  Does not appear in Menus and Toolbars -- AFAIK)

I realize that there may be problems with the cycling order (e.g., bug #88713 and #120938), but it would still be practical to be able to place a single reminder from the Find toolbar, without using a bookmark, and then Navigate by Reminder to get back).

In other words, this enhancement request is meant only to make it easier to use what is already coded in LO, while other bug reports about reminders are seeking to improve its possibilities.
Comment 1 Dieter 2019-12-20 08:00:01 UTC
Just for clarification: Do you mean bookmarks? I can't find "reminders" in Navigator. You can also create bookmarks with Insert => Bookmarks and you can add them to a toolbar.
Comment 2 sdc.blanco 2019-12-20 09:36:12 UTC
(In reply to Dieter Praas from comment #1)
> Just for clarification: Do you mean bookmarks?

No. I mean "reminder".

>  I can't find "reminders" in Navigator. 

F5 --  hover your mouse over the paperclip icon at the top of Navigator 
(in my version, it is the third icon in the second row).

The tooltip should say "Set Reminder"

> You can also create bookmarks with Insert => Bookmarks and you
> can add them to a toolbar.

Bookmarks requires handling a dialog box.  Reminders can be set simply by clicking on the icon. The request here is only to make the "paperclip" icon available for Customize, so that users can add it to a toolbar (rather than having to use Navigator). (I mentioned the Find toolbar, because there is a "Navigate by" for Reminders.)
Comment 3 Dieter 2019-12-20 10:19:23 UTC
(In reply to sdc.blanco from comment #2)
> (In reply to Dieter Praas from comment #1)
> > Just for clarification: Do you mean bookmarks?
> 
> No. I mean "reminder".
> 
> >  I can't find "reminders" in Navigator. 
> 
> F5 --  hover your mouse over the paperclip icon at the top of Navigator 
> (in my version, it is the third icon in the second row).
> 
> The tooltip should say "Set Reminder"

Yes, found it. I've never recognized it.

cc: Design-Team for further input
Comment 4 V Stuart Foote 2019-12-20 16:58:02 UTC
Yes 'Reminders' currently can only be set (aka dropped) from the Navigator deck (either Sidebar instance), it is the "paperclip" icon button. But then for use the Navigator must be placed in "Reminder" mode to navigate them.

Otherwise the 'Navigation' toolbar will add them to its object stack, its 'Back' and 'Forward' repositioning document/cursor focus.

These 'editviews' are very handy, and are the basis for <Shift>+F5 return to edit position. One is set to last text cursor position on save-exit from a document.

And, bug 92821 is open to expose them to repeated <Shift>+<F5> keyboard cycling, so adding ability to drop reminders from customized Toolbar of choice would make for better UX. And when the UNO action is done allowing customization, would expect the button would be added to the under resourced 'Navigation' Toolbar by default.
Comment 5 Jim Raykowski 2020-01-02 08:53:21 UTC
Would an uno command to "drop" a bookmark without use of the bookmark dialog work for this?
Comment 6 V Stuart Foote 2020-01-02 15:16:35 UTC
(In reply to Jim Raykowski from comment #5)
> Would an uno command to "drop" a bookmark without use of the bookmark dialog
> work for this?

IIRC bookmarks (unlimited number) get written out to the ODF archive, while reminders are transient and limited to 5.

So, for sure an UNO command to drop a 'Reminder', and possibly also an UNO command for 'Bookmarks'
Comment 7 Heiko Tietze 2020-01-06 11:41:02 UTC
We should keep the number of UNO commands low. Once it has been introduced it's very hard to remove a command without breaking macros. So if possible, I would enhance the existing .uno:InsertBookmark likewise done with .uno:StyleApply by some "...?direct=true".

The implementation of reminder is a mess. Unclear workflow/scenario with advantage over bookmarks, no feedback, some weird mode switch, different places to set and access, almost no documentation, an arbitrary limitation...
Comment 8 Maxim Monastirsky 2020-01-06 13:42:36 UTC
(In reply to Heiko Tietze from comment #7)
> So if possible,
> I would enhance the existing .uno:InsertBookmark likewise done with
> .uno:StyleApply by some "...?direct=true".
But doing it like this won't add an entry to the customization dialog, like the OP wants.
Comment 9 sdc.blanco 2020-01-06 14:28:10 UTC
(In reply to Maxim Monastirsky from comment #8)
> But doing it like this won't add an entry to the customization dialog, like
> the OP wants.
Thanks for highlighting this point.  And just to repeat from the initial report.
 
> this enhancement request is meant only to make it easier to
> use what is already coded in LO, while other bug reports about reminders are
> seeking to improve its possibilities.
I appreciate that "reminders" are not well-developed, but very practical for quickly marking and navigating to 1 or 2 places in a document (compared to bookmarks).  I would add it to my Find Toolbar, which already has a Navigate by Reminder function.
Comment 10 sdc.blanco 2020-01-06 14:34:36 UTC
(In reply to Heiko Tietze from comment #7)
> We should keep the number of UNO commands low. Once it has been introduced
> it's very hard to remove a command without breaking macros.
Sorry -- meant also to acknowledge this point. I just assumed (naively) that because there was an "Insert Reminder" (icon) in Navigator that this icon could also be made available to be added to a Toolbar.  Nothing deeper than that.
Comment 11 Jim Raykowski 2020-01-08 03:34:40 UTC
Here is a patch that adds an uno command that sets a reminder bookmark:

https://gerrit.libreoffice.org/c/core/+/86389

This along with patch for bug 88713 seem to make reminder bookmarks less messy.
Comment 12 Commit Notification 2020-01-09 09:30:11 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f31accb05a1c7064a7e586ffec8f283b6ff4787e

tdf#129468 Add uno command .uno:SetReminder to set a reminder bookmark

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Heiko Tietze 2020-01-09 13:07:46 UTC
Thanks Jim for code and Andreas, Rizmut for the icon. For consistency we should update the Navigator icon but the request should be fixed.
Comment 14 V Stuart Foote 2020-01-14 20:15:50 UTC
@Jim, Heiko, *

So tested with this on today's TB77 Windows build.

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 51882d9ec5a139bc7bc282ebf4ab03ada9ff2694
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

I am able to add the 'Set reminder'  [.uno.SetReminder] to Toolbars, though it still needs to be linked up to an icon--seems like the "paperclip" from the Navigator would be appropriate to reuse.

Unfortunately, not sure it is behaving exactly correct.

1. open Writer
2. Tools -> Customize
3. Toolbars tab
4. select Target 'Navigation'  (for the Navigation toolbar, see bug 85980)
5. 'Search' for "reminder"
6. add the command to the toolbar (arrow right)
7. force show the 'Navigation' toolbar, View -> Toolbars -> 'Navigation'
8. button text "Set Reminder" now showing (an Icon would be helpful)
9. dummy text, "dt" <F3>, into the Writer canvas
10. mouse point or cursor move around the text, use the new "Set Reminder" button to drop reminders

If working correctly, would expect the 'Back' and 'Forward' arrows from on the 'Navigation' toolbar will follow the reminders as set. Currently these buttons do not activate and have no action on the 'reminders' being set.

Shifting over to the 'Navigator' Sidebar deck and placing it into 'Reminder' mode. Seems may have a regression there--not necessarily from this, but it seems to affect it, maybe? Anyhow opened regression as bug 130004
Comment 15 Heiko Tietze 2020-01-15 13:37:34 UTC
The navigation toolbar contains of uno.NavigateBack and uno.NavigateForward while the Navigator itself neither runs any uno command nor uses the same functions; see the tooltips "Forward" vs. "Next Reminder". IIRC, the navigation toolbar was introduced in a GSoC project independently from any other interaction. So how to proceed?

The icons should have been added with https://gerrit.libreoffice.org/c/core/+/86443. @Andreas: Please double check your patch.
Comment 16 Rizal Muttaqin 2020-01-15 13:52:31 UTC
> I am able to add the 'Set reminder'  [.uno.SetReminder] to Toolbars, though
> it still needs to be linked up to an icon--seems like the "paperclip" from
> the Navigator would be appropriate to reuse.
For icon part I'm pretty sure the paperclip has been chosen with a reason. The "timefield" is not suitable IMHO. Another thing that Set Reminder function in sidebar Navigator is now still using a paperclip. Not so consistent though.
Comment 17 V Stuart Foote 2020-01-15 14:20:20 UTC
(In reply to Heiko Tietze from comment #15)
> The navigation toolbar contains of uno.NavigateBack and uno.NavigateForward
> while the Navigator itself neither runs any uno command nor uses the same
> functions; see the tooltips "Forward" vs. "Next Reminder". IIRC, the
> navigation toolbar was introduced in a GSoC project independently from any
> other interaction. So how to proceed?
> 

Nothing really to do with the 'Navigation' toolbar, just a convenient (and logical) UI Toolbar element to append to for testing. Testing these reminders as dropped via the new UNO command via the Navigator, when placed into Reminder mode, is equally valid. Regardsless of method, the reminders are probably functional but at the moment we can not navigate them!

Likewise a Tools -> Customize and adding the 'Bookmark' insert bookmark command to the Navigation toolbar behaves as the 'Reminder' insert reminder, and we have a regression bug 130004 in master that has now slipped into the 6.4.0 rc2 build with the Navigation mode dialog/Navigator button actions.

> The icons should have been added with
> https://gerrit.libreoffice.org/c/core/+/86443. @Andreas: Please double check
> your patch.

Maybe merged, but no icon yet appearing with the new command when searched/selected in the Customize, just the text label.
Comment 18 sdc.blanco 2020-01-15 14:36:30 UTC
(In reply to Jim Raykowski from comment #11)
> Here is a patch that adds an uno command that sets a reminder bookmark:
Many thanks for that Jim.

(In reply to V Stuart Foote from comment #17)
> the reminders are probably functional but at the moment we can not 
> navigate them!
Try "Navigate By" in Find toolbar.
Comment 19 V Stuart Foote 2020-01-15 15:16:59 UTC
(In reply to Heiko Tietze from comment #15)
> The navigation toolbar contains of uno.NavigateBack and uno.NavigateForward

Right, the commands on the Navigation toolbar control (navmgr) a dedicated shell (navsh) that includes multiple 'cursor objects' (SwUnoCursor) set for multiple objects on Writer canvas including reminders as set here. 

Alternatively, the Navigator is modal, and its displayed button actions depend on the selection made from its Navigation dialog. When placed into 'Reminder' mode, it gets those specific button actions.

For Navigator each mode type gets its own stack--with its own set of movement actions. For the Navigation toolbar, the modes are all merged, and the shell has awareness of its position on its stack.

The issues here of customization to drop a 'Reminder' we shouldn't conflate its simple action(s) with problems in either the Navigation toolbar or the Navigator deck.
Comment 20 V Stuart Foote 2020-01-15 16:09:36 UTC
Still needs an icon, and agree with comment 16 that the "paperclip" is more appropriate icon than using the "timefield".

Otherwise, reminders are being dropped. And, they can be traversed once mode is set--now only working from the <Ctr>+F 'findbar'.

Issues with the modes of Navigator, and the Navigation toolbar remains as bug 130004
Comment 21 Jim Raykowski 2020-01-30 22:29:36 UTC
Tested with:

Version: 7.0.0.0.alpha0+
Build ID: 5d7a526ee784abc3d83835b9e43047baf5dbe0b9
CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: kf5 and gen; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Paper clip icon is used for kf5 and x11. Assuming same for other VCL backends so setting this to Resolved Fixed.
Comment 22 V Stuart Foote 2020-01-31 02:52:00 UTC
Theme on Windows builds also are getting the papaerclip icon as well and shows in the Find bar and for the 'Available Commands' listbox.

Working great to customize the 'Navigation' Toolbar and use it to drop 'Reminder'  and traverse them from the toolbar.