Download it now!
Bug 129475 - FILEOPEN: DOCX: Incorrect nested table
Summary: FILEOPEN: DOCX: Incorrect nested table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:6.5.0 target:6.4.0.2
Keywords: bibisected, bisected, regression
: 129581 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-12-18 15:20 UTC by Xisco Faulí
Modified: 2020-01-07 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
comparison MSO 2010 and LibreOffice 6.5 Master (110.29 KB, image/png)
2019-12-18 15:20 UTC, Xisco Faulí
Details
Fix for the reported regression (3.56 KB, patch)
2020-01-03 20:58 UTC, László Németh
Details
test file with the reported regression (and with a new one) (183.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-03 21:01 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-18 15:20:02 UTC
Created attachment 156648 [details]
comparison MSO 2010 and LibreOffice 6.5 Master

Steps to reproduce:
1. Open attachment 101723 [details] from bug 80514

-> Nested table makes the image to be shifted to the right. See comparison

Reproduced in

Version: 6.5.0.0.alpha0+
Build ID: fb1eac64df88baae9f211d052793773686c0e180
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-12-18 15:21:07 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b2c6d2d961a6113d0f111fab45ae12a40d389a23

author	László Németh <nemeth@numbertext.org>	2019-12-05 09:47:18 +0100
committer	László Németh <nemeth@numbertext.org>	2019-12-08 15:54:01 +0100
commit	b2c6d2d961a6113d0f111fab45ae12a40d389a23 (patch)
tree	316cf6e0472f5c57a4d49d61d40ca5f3cc52e84d
parent	da1f71edfc72928b07a569b98e2766a8a7de9d2a (diff)
fdo#38414 tdf#44986: DOCX table import: handle gridBefore/After

Bisected with: bibisect-linux64-6.5

Adding Cc: to László Németh
Comment 2 László Németh 2020-01-03 20:58:47 UTC
Created attachment 156919 [details]
Fix for the reported regression
Comment 3 László Németh 2020-01-03 21:01:22 UTC
Created attachment 156920 [details]
test file with the reported regression (and with a new one)
Comment 4 Commit Notification 2020-01-04 09:32:18 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/adf7031e3a35fe9d43085e8b223a6e36d20a32f4

tdf#129475 DOCX: fix gridAfter with shape-only cells

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 László Németh 2020-01-04 09:37:07 UTC
Instead using the attached fix, I reverted the clean-up commit b2c6d2d961a6113d0f111fab45ae12a40d389a23 (fdo#38414 tdf#44986: DOCX table import: handle gridBefore/After), because I have found a second regression, too (see the attached test file).
Comment 6 Commit Notification 2020-01-06 11:22:18 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/4ddf3d035f8db1271df23b1e219a7c4a135297a3

tdf#129475 DOCX: fix gridAfter with shape-only cells

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-01-07 14:53:08 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@László, thanks for fixing the issue!
Comment 8 Xisco Faulí 2020-01-07 15:02:43 UTC
*** Bug 129581 has been marked as a duplicate of this bug. ***