Bug 129484 - Crash when trying to view property of a component from forms (gtk3)
Summary: Crash when trying to view property of a component from forms (gtk3)
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Linux (All)
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0.2 target:6.5.0 target:6.3.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-12-18 22:51 UTC by Julien Nabet
Modified: 2020-01-06 19:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with debug symbols (gtk3) (12.79 KB, text/plain)
2019-12-18 22:52 UTC, Julien Nabet
Details
bt with debug symbols (text box) (12.53 KB, text/plain)
2019-12-21 08:10 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2019-12-18 22:51:39 UTC
Description:
On pc Debian x86-64 with master sources updated today, I got a crash when trying to access properties of a component created in Form Design

Steps to Reproduce:
1. Launch Base with a brand new odb file (embedded hsqldb)
2. Click Forms at left panel
3. Click Create form in Design View...
=> a brand new empty form appears
4. Click "Option button"
5. draw a button
6. Right click on the button
7. Select "Form properties" or "Control properties"

Actual Results:
=> crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Julien Nabet 2019-12-18 22:52:20 UTC
Created attachment 156658 [details]
bt with debug symbols (gtk3)
Comment 2 Julien Nabet 2019-12-18 22:53:44 UTC
Caolán: thought you might be interested in this one since it's specific to gtk3.
Comment 3 Julien Nabet 2019-12-18 22:54:55 UTC
I don't think it's related but I noticed this on console:
warn:svx:384959:384959:svx/source/form/formcontrolfactory.cxx:178: DBG_UNHANDLED_EXCEPTION in rtl::OUString svxform::{anonymous}::lcl_getUniqueLabel_nothrow(const com::sun::star::uno::Reference<com::sun::star::beans::XPropertySet>&, const rtl::OUString&) exception: com.sun.star.uno.RuntimeException message: unsatisfied query for interface of type com.sun.star.container.XIndexAccess!
Comment 4 Xisco Faulí 2019-12-19 08:07:29 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=dead2a5b0eaae3fb33f9d2b4d249849864014585

author	Caolán McNamara <caolanm@redhat.com>	2019-12-11 14:22:30 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-11 17:07:55 +0100
commit	dead2a5b0eaae3fb33f9d2b4d249849864014585 (patch)
tree	451cfaa666a376795f9512f8a58abd40130bbe92
parent	ce4812ccda986386b16f0a77d443899f1f88aef6 (diff)
Resolves: tdf#128867 support LocalizedDecimalSep for native gtk dialogs

Bisected with: bibisect-linux64-6.5

Adding Cc: to Caolán McNamara
Comment 5 Xisco Faulí 2019-12-19 08:12:11 UTC
It can also be reproduced in Writer. Menu Forms - Option
Increasing severity since the problematic commit was backported to 6-4 and 6-3 branches
Comment 6 Commit Notification 2019-12-19 15:05:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a3909a3431bba2cb41c712a4e2fbc3747312e156

Resolves: tdf#129484 just install decimal key handler for spinbuttons

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2019-12-20 08:57:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e59bbb72b1145e4865742c5f03d9372a177b9df9

Resolves: tdf#129484 just install decimal key handler for spinbuttons

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-12-20 08:57:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2a5d4ed38df988077bcec62da331a7958ce0aaf3

Resolves: tdf#129484 install decimal key handler for all widgets again

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Julien Nabet 2019-12-21 08:10:52 UTC
Created attachment 156711 [details]
bt with debug symbols (text box)

On pc Debian x86-64 with master sources updated today, I don't reproduce the crash with Form properties/control properties on an option button but got an assert when trying to view properties on Text Box.

Do you want me to create a new bugtracker or do you think it's a bit related so not necessary?
Comment 10 Commit Notification 2019-12-23 11:32:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/60f469f585899e97f3dbc9b98b12d36d9b665eff

Resolves: tdf#129484 just install decimal key handler for spinbuttons

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-01-06 12:55:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aa528eadbf3f1fa46390ad5b25e0f4e3c89e0382

Related: tdf#129484 overeager assert

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-01-06 13:00:15 UTC
I think everything should be ok now
Comment 13 Julien Nabet 2020-01-06 19:33:19 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this anymore.
Thank you Caolán for the fix!