Bug 129504 - Breeze dark theme does not get selected automatically
Summary: Breeze dark theme does not get selected automatically
Status: RESOLVED DUPLICATE of bug 127138
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-19 21:10 UTC by stdcerr
Modified: 2020-04-02 03:36 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stdcerr 2019-12-19 21:10:17 UTC
Description:
A similar issue happened to me. I set the icon theme in Plasma under GNOME/GTK Application Style to Breeze Dark. Then, as I launched LibreOffice Draw, all the icons on the left in the DRaw toolbar, were invisible as they were black on very dark grey background and unter less than optimal lightning conditions, it simply is impossible to make out the icons. I essentially had to hover the cursor over each button to see the tooltip which would allow me to recognize where I clicked. I had to manually go to Tools - Options - LibreOffice - View and set the Icon style to Breeze (dark) upon whihc the icons appear perfectly fine.
No manual selection of the dark theme should be required ifit can be inherited from the global plasma configuration.


Steps to Reproduce:
Set Plasma Style to Breeze Dark, set Application Style > GNOME/GTK Application Style GTK2 theseme & GTK3 theme to Breeze-Dark, set Icon theme to Breeze Dark in Plasma's System Settings dialog.

Actual Results:
Draw will start with having its Icon style set to Breeze in Tools - Options - View dialog which leads to terrible contrast ratios for the icons in the program!

Expected Results:
The Icon Style in Draw shgould be set to Breeze (dark) automatically.


Reproducible: Always


User Profile Reset: No



Additional Info:

LSB Version:    1.4
Distributor ID: Arch
Description:    Arch Linux
Release:        rolling
Codename:       n/a
Comment 1 Timur 2020-04-01 07:03:50 UTC
I understand this is about icons. You need to search before reporting.

*** This bug has been marked as a duplicate of bug 127138 ***