Download it now!
Bug 129508 - Severe clipboard issues
Summary: Severe clipboard issues
Status: RESOLVED DUPLICATE of bug 62196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-20 03:22 UTC by info
Modified: 2019-12-20 06:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description info 2019-12-20 03:22:00 UTC
This bug affects Writer, Draw, Calc, and Impress.
This bug affects BOTH LO 6.3 and 6.2 on Ubuntu 19.10. Tested and confirmed on multiple machines.
This bug affects only 6.3 and not 6.2 on Ubuntu 18.04. Tested and confirmed on multiple machines. 
This bug affects only 6.3 and not 6.2 on Windows. Tested and confirmed and confirmed on multiple machines.

How bug works:
Copy something. Paste it somewhere. The first time will be fine. 
Copy a second thing. Attempt to paste it. 

Expected result: the second item will be pasted correctly. 

What actually happens: 
1: nothing
2: the first thing is pasted again as if the second thing were not copied
3: when the first thing was a picture or other graphical element it will paste the first again but it will be messed up.  Example, a textbox with text in it will become just a blue square.  Several pictures or shapes copied as a group will be pasted as a broken blue thing that can't be edited. Tables will paste as blue squares that again can't be entered or edited.  

On Ubuntu 19.10 using Libreoffice 6.2 these bugs can be sometimes avoided by exclusively using keyboard shortcuts and not the right click on the mouse or drop down menu from edit in the software.  Any mixing of keyboard shortcuts with either mouse right click menu or dropdown menu will almost always cause the bug. Right clicking with the mouse or using the drop down menu will almost always cause the bug but perhaps a little less often than mixing. Exclusively using keyboard shortcuts doesn't work with LO 6.3 on either Ubuntu or Windows but will seem to fix the problem on Ubuntu using 6.2. 

Another way to get around the problem in 6.3 is copy every thing that needs to be pasted two or three times. 

Example: Copy item one and then paste will work fine. Copy item two. Attempt to paste will cause either nothing to happen, item one to be pasted a second time, or a very broken version of item one to be pasted that can potentially corrupt the save file. 

New pattern (which isn't friendly to office workers): Copy item one and paste. Item 1 will paste just fine. Copy item 2. Then copy item 2 a second time. Just to be sure, copy item 2 a third time. Then paste item 2 and finally item 2 will paste correctly. Repeat multiple copies before pasting for EVERY SINGLE THING that needs to by copied and pasted. 

There are reports that Ubuntu 19.10 is having copy and paste issues with multiple applications such as Thunderbird mail and firefox browswer. The testing I have done shows that the only application affected by this particular bug is Libreoffice. On the machines I take care of Thunderbird and Firefox both work fine on 19.10 with no copy paste related issues. Also, this bug in Libreoffice 6.3 affects not only Ubuntu 19.10 but also 18.04 and Windows 10. On both 18.04 and Windows 10 using LO 6.2 the bug is not present but on both systems using LO 6.3 the bug is present. In Ubuntu 19.10 the bug is present in both 6.2 and 6.3. 

I hope that gives someone enough information to begin to track down the bug and get it fixed. Libreoffice is by far the best office software for our workloads and I'd like to be able to ask my staff to use it with confidence.
Comment 1 BogdanB 2019-12-20 06:11:46 UTC

*** This bug has been marked as a duplicate of bug 62196 ***