Download it now!
Bug 129513 - RTF file not displayed in correct format
Summary: RTF file not displayed in correct format
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.5.0 target:6.4.0.2 target:6.3.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2019-12-20 10:48 UTC by vlis.aztest
Modified: 2020-01-09 09:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test document for tdf#129513 (240.02 KB, application/msword)
2019-12-20 11:55 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlis.aztest 2019-12-20 10:48:13 UTC
Description:
Refer to RTF file sample https://drive.google.com/open?id=1E7MYAGt9nAyLwktGfbZJJPDGTreyiKkA
You may observe that the first 2 pages are displayed in a format that Traditional Chinese language content is on the left side while English language content is on the right side of the document. However, starting page 3, such formatting has been lost.
No such issue is observed when the document is opened in MS Word.

Steps to Reproduce:
Open the RTF file sample https://drive.google.com/open?id=1E7MYAGt9nAyLwktGfbZJJPDGTreyiKkA
and check the layout rendered

Actual Results:
You may observe that the first 2 pages are displayed in a format that Traditional Chinese language content is on the left side while English language content is on the right side of the document. 
However, starting page 3, such formatting has been lost.
No such issue is observed when the document is opened in MS Word.

Expected Results:
The format of the document on page 3 onwards is expected to be similar to first 2 pages. (can reference the layout rendered by MS Word).


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Mike Kaganski 2019-12-20 11:54:28 UTC
Reproducible with Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

The problem seems to be \pagebb keyword making both paragraphs in the "Part 2" row to have "page break before". Interestingly, the same keyword does not cause problems when the file is re-saved in Word (looks like the file was generated by some other software): LibreOffice simply ignores it (as it doesn't support page breaks as paragraph property inside tables).

Started from v.4.2. Was OK in 3.3.
Comment 2 Mike Kaganski 2019-12-20 11:55:45 UTC
Created attachment 156692 [details]
test document for tdf#129513
Comment 3 Mike Kaganski 2019-12-20 13:15:15 UTC
https://gerrit.libreoffice.org/85602
Comment 4 Commit Notification 2019-12-20 16:57:47 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/989043b0644354b92fd17e4194897c2eb0935031

tdf#129513: drop incorrect and redundant erasure of paragraph sprm

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-12-23 09:47:02 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 0322a41224a7264bbe03a068647ab093bcc88f90
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike, thanks for fixing this issue!
Comment 6 Commit Notification 2020-01-08 10:51:27 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a3fa368f1a50463e1540619834df31f48cba6a7d

tdf#129513: drop incorrect and redundant erasure of paragraph sprm

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-01-09 09:03:14 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1a4ede180585531f0bbabb877677b0e3b0319ee3

tdf#129513: drop incorrect and redundant erasure of paragraph sprm

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.