Download it now!
Bug 129518 - CF dialog - All cells - Color scale (2 or 3 items) => wrong layout for Russian UI
Summary: CF dialog - All cells - Color scale (2 or 3 items) => wrong layout for Russia...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.3.5 target:6.4.0.2
Keywords: bibisectRequest, regression
Depends on:
Blocks: Conditional-Formatting-Editing
  Show dependency treegraph
 
Reported: 2019-12-20 14:29 UTC by Roman Kuznetsov
Modified: 2020-01-07 16:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with a problem (11.41 KB, image/png)
2019-12-20 14:30 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-12-20 14:29:47 UTC
Description:
CF dialog - All cells - Color scale (2 or 3 items) => wrong layout for Russian UI

but for English UI it looks good more or less

Steps to Reproduce:
1. Open Calc
2. Set up Russian UI
3. Open Format->Conditional->Condition
4. Select All cells - Color scale
5. Look at layout (see a screenshot from attach)

Actual Results:
bad layout for Russian UI

Expected Results:
normal layout for Russian UI


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-12-20 14:30:25 UTC
Created attachment 156693 [details]
Screenshot with a problem
Comment 2 Xisco Faulí 2019-12-23 15:32:31 UTC
I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: 0322a41224a7264bbe03a068647ab093bcc88f90
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-12-23 15:35:17 UTC
nor in

Version: 6.5.0.0.alpha0+ (x64)
Build ID: b6f4d3b92789e972d9b079a5561723f3e73e07a6
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-12-23 15:36:08 UTC
@Caolán, do you reproduce this on your end ?
Comment 5 Aron Budea 2019-12-24 01:12:53 UTC
I can repro in 6.4.0.1 / Windows with Russian UI. Also in 6.3.0.4, but not in 6.2.0.3. I checked in Linux by hacking together bibisect repo + translation, and can't repro there, likely because the "Color Scale (3 Entries)" (in Russian) isn't displayed in full, and the dropdown is shorter.
Comment 6 Caolán McNamara 2020-01-06 13:30:20 UTC
I can reproduce this, seems to be triggered by a particularly long color name in Russian.
Comment 7 Commit Notification 2020-01-06 19:11:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/eb9b1469a6d0d11e94b50ce759910492dd6f8dfe

Resolves: tdf#129518 make colorboxes max width at 1/3 avail space

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2020-01-06 19:11:27 UTC
fixed in master, backports to 6-4 and 6-3 in gerrit
Comment 9 Commit Notification 2020-01-07 09:54:45 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/0e536aa4b173b5e2a370333e50f822883923dffc

Resolves: tdf#129518 make colorboxes max width at 1/3 avail space

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-01-07 11:37:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5dc17176f5194dc1e371b8de67aaa8813a117e94

Resolves: tdf#129518 make colorboxes max width at 1/3 avail space

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-01-07 16:29:24 UTC
@Roman, Could you please confirm the issue is fixed on your side ?
Comment 12 Roman Kuznetsov 2020-01-07 16:48:31 UTC
verified in

Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: 035c7717c135c66c0ec025500b73ae9c13b7c586
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

thanks Caolan!