Download it now!
Bug 129522 - FILEOPEN: DOCX: Incorrect borders in some paragraphys
Summary: FILEOPEN: DOCX: Incorrect borders in some paragraphys
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.5.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-12-20 15:22 UTC by Xisco Faulí
Modified: 2020-05-07 06:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (33.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-12-20 15:22 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.5 Master (172.41 KB, image/png)
2019-12-20 15:23 UTC, Xisco Faulí
Details
tdf129522_removeShadowStyle.odt: not a regression - existing bug (12.37 KB, application/vnd.oasis.opendocument.text)
2019-12-21 09:20 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-12-20 15:22:16 UTC
Created attachment 156696 [details]
sample file

Steps to reproduce:
1. Open attached document

-> Some paragraphs have bottom and right borders. Check screenshot

reproduced in

Version: 6.5.0.0.alpha0+
Build ID: dee81fb2e1df5091702b3c8b0e4a3f2b58e89291
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2019-12-20 15:23:17 UTC
Created attachment 156697 [details]
comparison MSO 2010 and LibreOffice 6.5 Master
Comment 2 Xisco Faulí 2019-12-20 15:24:26 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b47a8f091ad8f9048a6b7962e9cde5d04ea0d665

author	Justin Luth <justin.luth@collabora.com>	2019-08-01 15:50:00 +0300
committer	Justin Luth <justin_luth@sil.org>	2019-08-01 19:28:54 +0200
commit	b47a8f091ad8f9048a6b7962e9cde5d04ea0d665 (patch)
tree	ed81395e7a810280e79d969cef7a6575ea788a4f
parent	27c46ecf34b32bae1806d3fc0e1684179301feb8 (diff)
tdf#126544 writerfilter: check parent style exists before assigning

Bisected with: bibisect-linux64-6.4

Adding Cc: to Justin Luth
Comment 3 Justin L 2019-12-21 09:20:45 UTC
Created attachment 156714 [details]
tdf129522_removeShadowStyle.odt: not a regression - existing bug

This is a shadow setting that is being inherited from the "Block Text" style which specifies shadow=1 on the borders. Text body properly disables the borders, but the non-shadow is not overriding the inherited setting.

Not a regression - this has just exposed a pre-existing bug.

A round-trip "fixes" this since DOCX doesn't export shadow settings. (i.e. the shadow=1 is lost from Block Text style.)
Comment 4 Justin L 2019-12-21 14:50:45 UTC
proposed fix at https://gerrit.libreoffice.org/85658
Comment 5 Commit Notification 2020-01-03 11:14:20 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4ca73073a0d7c62b12a7354f76f8f80adc5d98c1

tdf#129522 SvxShadowItem/writerfilter: allow shadow_NONE overrides

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-01-04 14:39:24 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f84b33275f6cce21e93e5dd20f3de5df84df0276

tdf#129522 ww8import/export: allow char shadow_NONE overrides

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-01-07 16:49:40 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ccfccf4365362b5ba1d82b5816d5fc81a67de548

tdf#129522 writerfilter: allow char shadow_NONE overrides

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-01-09 09:37:35 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5c45b29f84c3421e1ad85c692ab8176cf15836a7

tdf#129522 ooxmlexport: allow char shadow_NONE override

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-01-09 12:50:54 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f7456777224f95654a179d7320e3e90fe42ce581

cleanup tdf#129522: indenting

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.