Download it now!
Bug 129597 - All 3 radiobuttons are selected in calc in Linux (GTK3)
Summary: All 3 radiobuttons are selected in calc in Linux (GTK3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.5.0 target:6.4.0.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-12-24 09:31 UTC by surbun
Modified: 2020-01-10 15:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Illustration of bug (81.21 KB, image/jpeg)
2019-12-24 10:04 UTC, surbun
Details
Screenshot to illstrate the issu (27.03 KB, image/jpeg)
2019-12-30 06:24 UTC, surbun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description surbun 2019-12-24 09:31:36 UTC
Description:
Every 3 radiobuttons are selected for updating external links

Steps to Reproduce:
1.Open LO
2.Open any calc file (new or recent)
3.Open "Tools" -> "Option" -> "LibreofficeDev Calc" -> "General"
4.Notice that all 3 radiobuttons are selected (see attached file)

Actual Results:
All 3 radiobuttons are selected

Expected Results:
Only one of the 3 radiobuttons can be exclusively selected


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Cause manual updating on opening files containing external links
Comment 1 surbun 2019-12-24 10:04:35 UTC
Created attachment 156769 [details]
Illustration of bug
Comment 2 Xavier Van Wijmeersch 2019-12-24 11:57:30 UTC
confirm with

Version: 6.5.0.0.alpha0+
Build ID: 1fd65c35f9cc44d94ac10e929b9c9c4bfb8d1afc
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Timur 2019-12-24 12:10:13 UTC
Reporter, confirmer, bug report and confirmation and not enough for a bug to be resolved. Most helpful is to confirm if this wasn't present before, because it's regression then and bibisectRequest may reveal how it came. I'm not on Linux now but I'll mark and set.
Comment 4 Xisco Faulí 2019-12-24 15:14:23 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5e95b239d53dba73d27d9d3d4e8e013636c0f283

author	andreas kainz <kainz.a@gmail.com>	2019-11-17 23:09:30 +0100
committer	andreas_kainz <kainz.a@gmail.com>	2019-11-18 08:22:18 +0100
commit	5e95b239d53dba73d27d9d3d4e8e013636c0f283 (patch)
tree	58cea760e52b8bd9f6f2a6eee07656f58076ef51
parent	9e7a0fc1573a95a1542207ac86a18e630c1fc835 (diff)
Options calc general tab only one column

Bisected with: bibisect-linux64-6.5

Adding Cc: to andreas kainz
Comment 5 Xisco Faulí 2019-12-24 15:25:39 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/85783/
Comment 6 Commit Notification 2019-12-26 08:14:27 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c6f6876ea1047a5f82b64b6fc9c835713e7d8bd

tdf#129597: Add missing group property

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xavier Van Wijmeersch 2019-12-26 19:48:12 UTC
@Xisco Fauli

Thanks it working again

Version: 6.5.0.0.alpha0+
Build ID: 49978d521b262595f9214cc7c2eac6ea824c511e
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: nl-BE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Commit Notification 2019-12-28 05:41:52 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c8e88aee3c058c57c96760cfb07a2330639cbc72

tdf#129597: Add missing group property

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 surbun 2019-12-30 06:24:02 UTC
Created attachment 156840 [details]
Screenshot to illstrate the issu

Hello,

It seems to be working (no request to do manual update of external link)

Yet in "Tools" -> "Options" -> "LibreofficeDev Calc" -> "General" all 3 radiobuttons are selected (see attached file)

Thanks for the patch

BS
Comment 10 Xisco Faulí 2020-01-07 10:48:10 UTC
(In reply to surbun from comment #9)
> Created attachment 156840 [details]
> Screenshot to illstrate the issu
> 
> Hello,
> 
> It seems to be working (no request to do manual update of external link)
> 
> Yet in "Tools" -> "Options" -> "LibreofficeDev Calc" -> "General" all 3
> radiobuttons are selected (see attached file)
> 
> Thanks for the patch
> 
> BS

Could you please paste the info from Help - about LibreOffice ?

I can't reproduce it in

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 surbun 2020-01-09 13:04:38 UTC
(In reply to Xisco Faulí from comment #10)
> (In reply to surbun from comment #9)
> > Created attachment 156840 [details]
> > Screenshot to illstrate the issu
> > 
> > Hello,
> > 
> > It seems to be working (no request to do manual update of external link)
> > 
> > Yet in "Tools" -> "Options" -> "LibreofficeDev Calc" -> "General" all 3
> > radiobuttons are selected (see attached file)
> > 
> > Thanks for the patch
> > 
> > BS
> 
> Could you please paste the info from Help - about LibreOffice ?
> 
> I can't reproduce it in
> 
> Version: 6.5.0.0.alpha0+
> Build ID: bf540873f5e258452fed5006f65a403c95e7872a
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded

Copy - Paste of "Help" - "About"

Version: 6.5.0.0.alpha0+
Build ID: a81489978cb96d819044be054f7ceabc4f8eccb2
Threads CPU : 4; OS : Linux 4.19; UI Render : par défaut; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-11-24_02:51:20
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 12 surbun 2020-01-10 15:50:21 UTC
Just installed the 9th January 2020 version.
This time, only one of the radio buttons is selected.

So everything is OK.

Thanks
BS