Download it now!
Bug 129604 - Extra/broken help content packaged with installer
Summary: Extra/broken help content packaged with installer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: All All
: medium major
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.4.1
Keywords: notBibisectable, regression
Depends on:
Blocks: Help
  Show dependency treegraph
 
Reported: 2019-12-25 03:42 UTC by Aron Budea
Modified: 2020-06-04 09:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-12-25 03:42:50 UTC
Install LO 6.4.0.1.

=> There's a 'help' directory with ~50-80 MB media files and a bunch of generic/helper css/html/js/xsl files (no actual help content).

This is a regression in 6.4 compared to 6.3. The installer is comparably larger because of the extra content as well.
Comment 1 Olivier Hallot 2019-12-31 21:49:16 UTC
Verified in a widows build in master, but I am not sure if this is not "working as designed". The full help is packaged with the main software.
Comment 2 Aron Budea 2020-01-10 14:34:35 UTC
Bug is still in 6.4.0.2. I don't see the help itself packaged with the main software, pressing F1 in LO opens a dialog that built-in help isn't installed on my computer, and prompts me to read help online.

The extra content is really just a bunch of screenshots as far as I can see, some in several languages. Eg. there's a single 'help/media/screenshots/cui/ui/charnamepage/CharNamePage.png' image, but there are many 'help/media/screenshots/cui/ui/effectspage/<language code>/EfefectsPage.png' files.
Comment 3 Commit Notification 2020-01-16 00:54:16 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/help/commit/191058eba782a34dad89959d5a20d6f2edd4bc3a

tdf#129604 Place localized images in right makefile
Comment 4 Olivier Hallot 2020-01-23 12:04:13 UTC
The patch resolves part of the issue and build must have "--without-helppack-integration" to isolate the Help packaging from the main package.

But still many media files are sent to main packages (screenshots/, files/ ) with no need.