Download it now!
Bug 129622 - Layout problem, listbox width too wide, in Options-LibreOffice-View dialog for RU GUI
Summary: Layout problem, listbox width too wide, in Options-LibreOffice-View dialog fo...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.5.0 target:6.4.0.2
Keywords: bibisectRequest, regression
Depends on:
Blocks: Options-Dialog-View
  Show dependency treegraph
 
Reported: 2019-12-26 06:56 UTC by Roman Kuznetsov
Modified: 2020-01-08 16:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with problem (126.24 KB, image/png)
2019-12-26 06:57 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-12-26 06:56:40 UTC
Description:
Layout problem in Options-LibreOffice-View dialog for RU GUI (see attach)

Steps to Reproduce:
1. Set RU GUI
2. Open Tools-Options-LibreOffice-View
3. Look at labels in Icon size section

Actual Results:
wrong view

Expected Results:
normal view


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-12-26 06:57:23 UTC
Created attachment 156780 [details]
Screenshot with problem
Comment 2 Xisco Faulí 2019-12-26 12:02:47 UTC
not reproduced in

Version: 6.5.0.0.alpha0+
Build ID: 1abfc8e2f677024ea058e96f3133e503ba89ea02
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 V Stuart Foote 2019-12-26 15:38:27 UTC
Confirmed on Windows 10 Home 64-bit en-US with LibreOffice set to RU locale.
Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: 0640bbac3c0b9e51e659c1d2b86d9a79a6dfa225
Потоков ЦП: 4; ОС:Windows 10.0 Build 18362; Отрисовка ИП: Skia/Vulkan; VCL: win; 
Локаль: ru-RU (en_US); Язык интерфейса: ru-RU
Calc: threaded

In this locale, the Tools -> Options -> View panel, the field labels for the 'Icon Size:' (i.e. Toolbar:, Notebookbar, Sidebar) are being obscured the the listbox holding the icon sizes (automatic, small, large, extra-large).  The width for the listbox seems too wide and while anchored right is entries are aligned left.
Comment 4 V Stuart Foote 2019-12-28 14:22:17 UTC
Looks to be with the GTK ComboBoxText grid work in https://gerrit.libreoffice.org/c/core/+/82473  does each icon size item list also need an hexpand?

@Andreas?
Comment 5 Heiko Tietze 2020-01-06 12:50:00 UTC
Weird, let's see if https://gerrit.libreoffice.org/c/core/+/86275 fixes the issue.
Comment 6 Heiko Tietze 2020-01-06 14:02:36 UTC
Please verify
Comment 7 Commit Notification 2020-01-06 14:02:54 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/beed7183ac6323eb052e7c586d6a807fcb32eb1f

Resolves tdf#129622 - Layout problem in Options-LibreOffice-View

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-01-07 16:30:26 UTC
(In reply to Heiko Tietze from comment #6)
> Please verify

@Roman, could you please verity the issue is fixed on your end ?
Comment 9 Roman Kuznetsov 2020-01-07 16:47:30 UTC
verified in

Версия: 6.5.0.0.alpha0+ (x64)
ID сборки: 035c7717c135c66c0ec025500b73ae9c13b7c586
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

thanks Heiko!
Comment 10 Commit Notification 2020-01-08 16:31:27 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/f2d54bb55d23d000d2c69860cb145ae379e1ea10

Resolves tdf#129622 - Layout problem in Options-LibreOffice-View

It will be available in 6.4.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.