Bug 129684 - UI: Presenter Console: Mouse move scrolling switches slide
Summary: UI: Presenter Console: Mouse move scrolling switches slide
Status: RESOLVED DUPLICATE of bug 127921
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-29 11:31 UTC by dldld
Modified: 2019-12-30 14:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Presentation with enought slides to get a scroll bar in the Presenter Console on an HD screen (27.58 KB, application/vnd.oasis.opendocument.presentation)
2019-12-29 11:33 UTC, dldld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dldld 2019-12-29 11:31:27 UTC
Description:
In the Impress Presenter Console in the Slides View, "scrolling" with the mouse by dragging the scrollbar switches on MouseUp to the next slide. No matter which position the mouse has, on the mouse up event.


Steps to Reproduce:
1. Open a new Presentation e.g. from Template Focus. Copy and paste slides to get enough slides (>40) so that the Presenter Console will show a scroll bar
2. Start the Presentation with F5
3. Drag the scroll bar

Actual Results:
The presentation switches to the next slide when the mouse up event happens.

Expected Results:
The view has been scrolled and the presented slide hasn't changed.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.3.2
Build ID: 1:6.3.3-0ubuntu0.19.10.1
CPU threads: 12; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 580 Series (POLARIS10, DRM 3.33.0, 5.3.0-24-generic, LLVM 9.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.2.1
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.5 (Compatibility Profile) Mesa 19.2.1
OpenGL shading language version string: 4.50
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 19.2.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

On another newly install Ubuntu Mate this also occurred.
Comment 1 dldld 2019-12-29 11:33:07 UTC
Created attachment 156832 [details]
Presentation with enought slides to get a scroll bar in the Presenter Console on an HD screen
Comment 2 dldld 2019-12-30 14:01:18 UTC
Also happens on Windows:

Version: 6.3.3.2 (x64)
Build-ID: a64200df03143b798afd1ec74a12ab50359878ed
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL
Comment 3 dldld 2019-12-30 14:18:22 UTC
Seems to be fixed in 6.3.4.2:

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL

*** This bug has been marked as a duplicate of bug 127921 ***