Download it now!
Bug 129690 - FILEOPEN DOCX: import microsoft word bibliography broken after reload
Summary: FILEOPEN DOCX: import microsoft word bibliography broken after reload
Status: RESOLVED DUPLICATE of bug 89506
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2019-12-29 17:38 UTC by rupert.thurner
Modified: 2020-05-09 20:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
word docx with one bibliography entry and screenshot how it should look like (57.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-12-29 17:38 UTC, rupert.thurner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rupert.thurner 2019-12-29 17:38:03 UTC
Created attachment 156838 [details]
word docx with one bibliography entry and screenshot how it should look like

the attached document contains one bibliography entry with a reference to it. opening in writer does not work. the document contains a screenshot how the entry looks like in microsoft word. when updating the bibliography, it is destroyed.

Version: 6.3.4.2.0+
Build ID: 6.3.4-1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-12-30 10:41:09 UTC
I confirm it with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

in comparison with MS Word 2016
Comment 2 Timur 2020-03-16 15:05:19 UTC
Is this a duplicate of bug 89506?
Comment 3 rupert.thurner 2020-05-09 20:13:08 UTC
i think  so timur, should we close this and upload the doc there?
Comment 4 rupert.thurner 2020-05-09 20:26:03 UTC
did upload it so you r free to leave one of the bugs open or both.
Comment 5 Dieter 2020-05-09 20:32:31 UTC

*** This bug has been marked as a duplicate of bug 89506 ***