Download it now!
Bug 129702 - [UI] Smart tags wrongly listed in AutoCorrect options dialog
Summary: [UI] Smart tags wrongly listed in AutoCorrect options dialog
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords:
Depends on:
Blocks: GTK3 AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2019-12-30 17:10 UTC by jeanmarczambon
Modified: 2020-05-03 07:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Smart Tags tab (39.09 KB, image/png)
2020-04-30 17:21 UTC, Buovjaga
Details
Actual smart tags option page (28.65 KB, image/jpeg)
2020-05-01 13:32 UTC, jeanmarczambon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jeanmarczambon 2019-12-30 17:10:29 UTC
Description:
When one or more smart tags extensions are installed, the available smart tag types should be listed in the "Smart Tags" tab of the AutoCorrect options dialog (Tools -> AutoCorrect -> AutoCorrect Options...), following the scheme "<smart tag caption> (<recognizer name>)".

This works fine in OpenOffice. In LibreOffice, the names are all replaced by the boolean strings "TRUE" or "FALSE", according to the check box status. It's therefore impossible to know which smart tag types are active or not.

If needed, one can test with this smart tags extension from Hanya: https://forum.openoffice.org/en/forum/viewtopic.php?p=387917#p387917.

Steps to Reproduce:
1. install a smart tags extension (see link above if needed);
2. restart the program;
3. open the AutoCorrect options dialog and see the "Smart Tags" tab.

Actual Results:
The listbox only shows "TRUE" or, if unchecked, "FALSE".

Expected Results:
The listbox should show the smart tag caption and its recognizer name.


Reproducible: Always


User Profile Reset: No



Additional Info:
It probably happens in "FillListBox" from cui/source/tabpages/autocdlg.cxx (l. 2178), but I'm unable to really understand the C++ code.
Comment 1 Dieter 2019-12-31 08:15:45 UTC
I can't confirm this with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: e26d89371f0e4f41476c9a99be01d98dedb76776
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 2 jeanmarczambon 2019-12-31 11:08:21 UTC
I forgot to specify I was testing on a linux machine (Linux Mint 19.3) in a french environment.

The problem still occurs with 6.4.0.0.


Version: 6.4.0.0.alpha1
Build ID: cc57df8f942f239d29cb575ea5a7cb01405db787
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: fr-BE (fr_BE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Buovjaga 2020-04-30 17:21:26 UTC
Created attachment 160142 [details]
Screenshot of Smart Tags tab

Here is how it looks like for me. Is it OK?

Arch Linux 64-bit
Version: 7.0.0.0.alpha0+
Build ID: 623d6cf06ccba392c1993a3b0ad271d508205e73
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 29 April 2020
Comment 4 jeanmarczambon 2020-05-01 13:32:58 UTC
Created attachment 160181 [details]
Actual smart tags option page

Yes, correct, this is how it should look like.
Here is what I get instead, either with LibO 6.3, 6.4, 6.5 alpha or 7.0 alpha.

Version : 6.4.3.2
Build ID : 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
Threads CPU : 4; OS : Linux 5.3; UI Render : par défaut; VCL: gtk3; 
Locale : fr-BE (fr_BE.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 5 Buovjaga 2020-05-01 15:13:38 UTC
Ah, OK, I repro with gtk3 backend. Not sure if this should fall under gtk3 meta or gtk3 whipping boy bug 122043 or if this is due to something that should be changed in the extension
Comment 6 Commit Notification 2020-05-01 19:09:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/161fde0052c6d0616ba54a0799e84d58b2c80688

Resolves: tdf#129702 take text from correct model column

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2020-05-01 19:10:21 UTC
fixed in master, backport to 6-4 in gerrit
Comment 8 Buovjaga 2020-05-02 11:33:45 UTC
Verified, thanks!

Arch Linux 64-bit
Version: 7.0.0.0.alpha0+
Build ID: 05b87ae66ebccd06995cf530b860443ad9503b31
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 2 May 2020
Comment 9 jeanmarczambon 2020-05-02 16:31:58 UTC
Damned! Thanks ;-) .
Comment 10 Commit Notification 2020-05-03 07:21:30 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a070dfba618ceda6d3b17b27f6fa233e4cedb3e2

Resolves: tdf#129702 take text from correct model column

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.