Bug 129703 - specific form based sheet gets empty/invisible menu options and no mouseover comment pop-out in LO 6.4.0.1 WIN10 x64 with OpenGL (and Skia for master/6.5.0)
Summary: specific form based sheet gets empty/invisible menu options and no mouseover ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2019-12-30 17:27 UTC by karsten.henning
Modified: 2020-01-03 03:26 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
empty menu in Calc (15.20 KB, image/png)
2019-12-30 17:30 UTC, karsten.henning
Details
opengl_device.log (316 bytes, text/plain)
2020-01-02 08:35 UTC, karsten.henning
Details
Help -> About LibreOffice (27.66 KB, image/png)
2020-01-02 09:50 UTC, karsten.henning
Details
Calc-File with spreadsheets (126.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-01-02 16:11 UTC, karsten.henning
Details
Linux: Help--> About (60.89 KB, image/png)
2020-01-02 16:14 UTC, karsten.henning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karsten.henning 2019-12-30 17:27:33 UTC
Description:
After updating to version 6.4.0.1 no more menu options in a Calc file. The Calc file uses conditional formatting and is saved with password.
A new file with conditional formatting does not have this effect.
Also without this effect the file can be opened in the same Linux version.
This is due to Windows 10 (1803). 

Actual Results:
no more menu options in a Calc file

Expected Results:
All menu options in a Calc file


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 karsten.henning 2019-12-30 17:30:52 UTC
Created attachment 156855 [details]
empty menu in Calc

This is a Screenshot
Comment 2 V Stuart Foote 2019-12-31 04:17:42 UTC
Please post text of Help -> About LibreOffice

and the text from your OpenGL device log:

C:\Users\<yourname>\AppData\Roaming\LibreOffice\4\cache\opengl_device.log

Then, check behavior if you enable/disable OpenGL rendering:

Tools -> Options -> View: 'Use OpenGL for all rendering'

do the empty menus appear with or without OpenGL rendering, or Hardware Acceleration checked enabled.
Comment 3 karsten.henning 2020-01-02 08:35:05 UTC
Created attachment 156895 [details]
opengl_device.log

C:\Users\<yourname>\AppData\Roaming\LibreOffice\4\cache\opengl_device.log
Comment 4 karsten.henning 2020-01-02 08:38:58 UTC
The option OpenGL was enabeld. After disabling the menu options appear again, but the display is sometimes very slow.
Comment 5 karsten.henning 2020-01-02 09:25:43 UTC
In Calc, no comments appear when the mouse is moved over the cells.
Comment 6 karsten.henning 2020-01-02 09:50:47 UTC
Created attachment 156897 [details]
Help -> About LibreOffice

Please post text of Help -> About LibreOffice
Comment 7 V Stuart Foote 2020-01-02 15:13:55 UTC
The Graphics driver installed for your HD Graphics 4600 on your Xeon E3 series CPU is a bit out of date. Current build from Intel is the .5063 from March 2019 [1].

Please update driver and retest rendering. Both with and without OpenGL rendering, and with and without Hardware Acceleration checked active.

=-ref-=

[1] https://downloadcenter.intel.com/download/28662/Intel-Graphics-Driver-for-Windows-15-40-
Comment 8 karsten.henning 2020-01-02 16:01:57 UTC
Sorry, my computer with Win10 is a company device and is administered centrally. I am not allowed to install other drivers.
By the way, I notice the same behaviour under Linux as described in my comment 5. I enclose the special file and the system description.
Comment 9 karsten.henning 2020-01-02 16:11:25 UTC
Created attachment 156905 [details]
Calc-File with spreadsheets

In spreadsheet "Übersicht" the mouse-over lets appear the comments but in spreadsheet  "Planung" you can create one and after moving the mouse over the cell no comment appears.
This behaviour cannot be explained to me and is only visible as of LO6.4.0.1.
Comment 10 karsten.henning 2020-01-02 16:14:16 UTC
Created attachment 156906 [details]
Linux: Help--> About

Screenshot of Help--> about
Comment 11 V Stuart Foote 2020-01-02 19:07:17 UTC
So, this is weird! 

In attachment 156905 [details], I am seeing a rendering issue (empty menus) but just with sheet/table:name="Planung"

And this is am on Windows 10 64-bit en-US (1903) with nVidia Quadro K2000 GPU (driver 26.21.14.4128, Nov 2019)

With OpenGL rendering enabled no issue with
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


but with recent master/6.5.0 (TB77 build 2019-12-31)
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 444f0d256957544d26b9af9a0898364e829df1b5
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

and for the 6.4.0.1 release build (/a Administrative install)
Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Just this sheet/table:name="Planung" for the ODS archive, UI Context menus and Main menu render blank, and the pop-up comment in cell D8 is not opening.

Other sheets of the document have no issue and do open context/main menus, and show the pop-up comments on mouse over.

Weird issue on this sheet also affects the new Skia/Vulkan rendering on the master/6.5.0 build.
Comment 12 V Stuart Foote 2020-01-02 19:10:28 UTC
(In reply to V Stuart Foote from comment #11)

Should add, with 6.4.0.1 and master/6.5.0 menus are fine with default CPU rendering and with Hardware Acceleration--though the comment in D8 still does not pop-up on mouse over.