Bug 129704 - hyphenation with big string and wrap picture bad on first line
Summary: hyphenation with big string and wrap picture bad on first line
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyphenation
  Show dependency treegraph
 
Reported: 2019-12-30 20:51 UTC by noscollections
Modified: 2020-12-19 17:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A long line and an image with page wrap (105.16 KB, application/vnd.oasis.opendocument.text)
2019-12-30 21:05 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description noscollections 2019-12-30 20:51:57 UTC
Description:
type a very long string in a writer document. The test is better if you do a string that cover many lines (10 lines). At the end of the line, the continuation continues on the next line and this for the 10 lines. This is normal.
Now I insert a picture in the document with wrap to "page wrap" or " "optimal page wrap" or left or right wrap.
put the picture a the right of the page, under the string.
Move up the picture to be inside the string.AT the begining this is good. But if the picture cross the first line of the string, the first line can't be break by hyphenation and all the paragraph is move to the buttom of the picture.
So paragraph presentation is wrong with the picture.
I have see this probleme since several versions.


Steps to Reproduce:
1.type a very ling string in writer (10 lines)
2.insert picture (width 4cm for exemple)
3.put the picture on the right of paragraph string
4. if the picture cross the first string line, all the string if move under the picture

Actual Results:
all the string if move under the picture

Expected Results:
1er line must be break by hyphenation like the line 2 and the next to have a correct presentation. Like a paragrapheof several lines with words.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
test with several windows versions, also in linux 4.3.3.2

if you put textbox and not picture, the problem is the same
Comment 1 Mike Kaganski 2019-12-30 21:04:23 UTC
Repro - also with OpenOffice.org 3.2.0 OOO320m12 (Build:9483).
Comment 2 Mike Kaganski 2019-12-30 21:05:54 UTC
Created attachment 156858 [details]
A long line and an image with page wrap

Trying to move the image up (e.g., clicking it and then pressing arrow up key) will demonstrate the problem.
Comment 3 BogdanB 2020-12-19 17:08:38 UTC
It still happend.
Tested in
Version: 7.0.4.2
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded