Download it now!
Bug 129730 - FILESAVE: Tables in writer docx file slightly shifted left outside of the text boundary when opened with MS word
Summary: FILESAVE: Tables in writer docx file slightly shifted left outside of the tex...
Status: RESOLVED DUPLICATE of bug 106742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Tables DOCX-compatibilityMode-15
  Show dependency treegraph
 
Reported: 2020-01-02 05:59 UTC by Michelle
Modified: 2020-03-13 10:08 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File which causes the bug (4.35 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-02 06:01 UTC, Michelle
Details
Side by side comparison image (81.27 KB, image/png)
2020-01-02 06:02 UTC, Michelle
Details
Reproducer odt from 6.5master (8.39 KB, application/vnd.oasis.opendocument.text)
2020-01-06 08:12 UTC, NISZ LibreOffice Team
Details
Screenshot of the reproducer exported from 5.3.0 and 5.4.0 (38.12 KB, image/png)
2020-01-06 08:54 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michelle 2020-01-02 05:59:46 UTC
Description:
Tables in a docx file saved from writer will display slightly to the left, outside of the text boundary, when opened in ms word 2016 / 2019, compared to writer (see comparison image).

In ms word, clicking "File -> Info -> Convert" will resolve the difference.

Steps to Reproduce:
1. Create new file in writer, type some text and insert a table, type some text into the table, save as docx.
2. Compare file in writer and ms word.

Actual Results:
In word the text inside and outside of the table will be aligned evenly and the table will be outside the text boundary. in writer the text will not be even and the table will be inside the text boundary.

Expected Results:
Tables should be rendered the same in writer and word.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Additional Info:
Version: 6.2.8.2 (x64)
Build ID: f82ddfca21ebc1e222a662a32b25c0c9d20169ee
CPU threads: 16; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: en-AU (en_AU); UI-Language: en-US
Calc: CL
Comment 1 Michelle 2020-01-02 06:01:14 UTC
Created attachment 156893 [details]
File which causes the bug
Comment 2 Michelle 2020-01-02 06:02:27 UTC
Created attachment 156894 [details]
Side by side comparison image
Comment 3 Durgapriyanka 2020-01-02 17:13:02 UTC
Thank you for reporting the bug. I can reproduce the bug in

Version: 6.4.0.0.alpha1+ (x86)
Build ID: ec7374ff84c71edfbb30d6e4dc5b486b6df7107f
CPU threads: 2; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-11-10_21:37:30
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
	

But, not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 4 NISZ LibreOffice Team 2020-01-06 08:12:22 UTC
Created attachment 156957 [details]
Reproducer odt from 6.5master

Repro with this simple example file with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 0ad51b30556f96bff0d78cc540781416c1ea6b8b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2020-01-06 08:54:14 UTC
Created attachment 156958 [details]
Screenshot of the reproducer exported from 5.3.0 and 5.4.0

Looks like this is a regression that started to appear in 5.4
Comment 6 NISZ LibreOffice Team 2020-01-15 15:28:44 UTC
Bibisected using bibisect-win32-5.4 to:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a31d1c83e08600507689dc18f6f0973bc7e4389


author
Vitaliy Anderson <vanderson@smartru.com> 2017-04-04 17:11:12 +0300 

committer
Mike Kaganski <mike.kaganski@collabora.com> 2017-04-17 13:11:53 +0200 

tdf#106742: OOXML import/export: treat "tblInd" properly
Comment 7 Justin L 2020-03-13 10:08:12 UTC
Fixed in 6.3.6 and 6.4.2 

by commit d978f5d40102a098f1faf1e98aa39ad122284299
Author: Michael Stahl  Mon Feb 10 19:20:03 2020 +0100
    related: tdf#106742 sw: DOCX import/export: fix default of table indent
    
    There's a compatibilityMode in word/settings.xml in DOCX files:
    https://docs.microsoft.com/en-us/openspecs/office_standards/ms-docx/90138c4d-eb18-4edc-aa6c-dfb799cb1d0d
    
    If a document doesn't contain compatibilityMode, then the default
    is 12, but the code for table indent import/export assumed that the
    default is 15, so loading an ODF document and exporting as DOCX results
    in wrong table indent when loaded in Word.
    
    (regression from 9a31d1c83e08600507689dc18f6f0973bc7e4389)

*** This bug has been marked as a duplicate of bug 106742 ***