Bug 129760 - Empty "Input field" not highlighted under Windows (see c11-c14)
Summary: Empty "Input field" not highlighted under Windows (see c11-c14)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-03 15:48 UTC by sdc.blanco
Modified: 2022-01-07 13:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Field highlighting with LibreOffice Still (55.40 KB, image/png)
2020-01-06 11:10 UTC, Heiko Tietze
Details
simple illustration of user field (11.03 KB, application/vnd.oasis.opendocument.text)
2020-01-06 13:38 UTC, sdc.blanco
Details
Empty field (10.85 KB, image/png)
2020-01-06 13:39 UTC, Heiko Tietze
Details
screenshot of input fields (10.79 KB, image/png)
2020-01-06 15:19 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-03 15:48:42 UTC
To see the problem:

1. Open attachment 155996 [details]

2. Put some blank spaces after the field ("New value")

3. Edit the field (e.g. double-click and remove "New value" in dialog box, OK)

4. Place cursor somewhere else (e.g., end of file)

Result:  The field becomes "invisible"  (e.g., try to find it with a mouse click)

It can be found by moving the cursor (e.g., with the arrow key) until you land on it.  


Expected result (enhancement request):  To leave some kind of "trace" so that a user knows that the input field is present -- even if empty.
Comment 1 V Stuart Foote 2020-01-03 18:51:49 UTC
Think the usage is to use <Ctrl>+<F9>, or main menu View -> 'Field Names' which will toggle display of the Field Name and type or the string value of the field.

Example is "invisible" because when created you did not give it a Field Name, just the string value, which you'd then cleared.

But what has been annoying to me is that the Fields do not show in Navigator--nor record an object for movement via the Navigation toolbar. 

Seems like they should, especially when they _are_ named.

@Cor, Regina?
Comment 2 sdc.blanco 2020-01-03 19:19:12 UTC
(In reply to V Stuart Foote from comment #1)
> Think the usage is to use <Ctrl>+<F9>, or main menu View -> 'Field Names'
> which will toggle display of the Field Name and type or the string value of
> the field.

I understand.  But in this particular use case, with an Input Field, it should be visible.  Not dependent on Ctrl-F9. 

> Example is "invisible" because when created you did not give it a Field
> Name, just the string value, which you'd then cleared.

This example was created by another person (with 6.3.0.0), which may explain why Ctrl-F9 does not work.  (It does work with 6.5.0.0).  

But where can one give a Field name in the Fields dialog?
Comment 3 sdc.blanco 2020-01-04 23:02:04 UTC
Additional information.

Ctrl-F9 does not show field codes for Input Field variables created with a Text or User variable

Systematic procedure to see problem.

1.  Create (and insert) a variable with Text format.
2.  Create (and insert) a variable with General Format and alphabetic value 
(e.g., abcd) (I know.  But this is to illustrate a point.) 
3.  Create a User Field, with General Format and alphabetic value.
4.  Insert three input fields, one with each variable.

Actual Result:  
 - Text format variable is displayed 
 - General format variable displays (little) grey box
 - User Field (with General format) shows alphabetic value
 - Input field with Text and User displays text
 - Input field with General displays (little) grey box.

Part II.

Create and insert a User Field (with no value).
Note that a grey box is shown.

Part III.

View > Field Names (Ctrl+F9)

Actual Result:
 - Input field with Text and User variables do not show field names
 - All other fields display their contents (including the alphabetic values for the General Format variable)

Observations.
1.  Even though the input field with a General variable and the empty User Field does not show anything, the field itself is still shown with a grey box.
2.  Similarly, Ctrl-F9 shows the codes for the General variable Input field box, but no field name codes are shown for the input boxes with Text and User variables.
3.  As noted before, if you remove the contents (value) of the Text format or User format variables, then the Input box becomes invisible, unless you move the cursor until you "notice" that have have entered the field again. 

Retested with LO 6.3.4.2  and same results with:

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 444f0d256957544d26b9af9a0898364e829df1b
CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win;
Comment 4 Heiko Tietze 2020-01-06 10:42:35 UTC
We have view > field shadings / ctrl+f8 to always identify fields (and some formatting marks). Speaking more generally you don't want to see fields but a kind of pixel-perfect print preview. And this variable input is rather a constant not meant to flexible enter data like done with form > text box, and other. So my take => WF.

(In reply to V Stuart Foote from comment #1)
> But what has been annoying to me is that the Fields do not show in
> Navigator--nor record an object for movement via the Navigation toolbar. 

Absolutely, different topic though and I bet we have a ticket on this.
Comment 5 sdc.blanco 2020-01-06 11:07:17 UTC
(In reply to Heiko Tietze from comment #4)
> We have view > field shadings / ctrl+f8 to always identify fields (and some
> formatting marks). 

That would be fine with me, but in this case Ctrl-f8 does not show anything.
Comment 6 Heiko Tietze 2020-01-06 11:10:12 UTC
Created attachment 156961 [details]
Field highlighting with LibreOffice Still
Comment 7 sdc.blanco 2020-01-06 12:11:56 UTC
(In reply to Heiko Tietze from comment #6)
> Created attachment 156961 [details]
> Field highlighting with LibreOffice Still
In your example:
1. Please double-click on "New value", which should open "Review Fields" dialog box.
2. Delete string "New value" (so that dialog box is empty).
3. Ok
Then you should be able to see the problem (i.e, the input field is not visible, and does not appear with ctrl+f8 or ctrl-f9).
Comment 8 Heiko Tietze 2020-01-06 12:25:33 UTC
Minimum width even for empty fields? Might be wanted to have zero width when empty.
Comment 9 Regina Henschel 2020-01-06 13:28:08 UTC
Width should be zero, but it should have a field shading, similar as a soft hyphen has even a shading, when it is not at the end of a line and therefore not written.

If you go with the cursor over the input field using the arrow keys, you see a change in the cursor type, when you are inside the field. But that does not help, if you don't know, that there is an input field because there is no visual hint.

I support the request for a visible hint for empty input fields.
Comment 10 sdc.blanco 2020-01-06 13:38:18 UTC
Created attachment 156963 [details]
simple illustration of user field

(In reply to Heiko Tietze from comment #8)
> Minimum width even for empty fields? Might be wanted to have zero width when
> empty.
If this was a question for me...
...my only concern was to be able to see the field (e.g., with ctrl-f8)
...was not trying to propose enhancement or UX design.

If "zero width" has printing implications, then "zero width" might be preferred.
Simpled-minded illustration attached.
Comment 11 Heiko Tietze 2020-01-06 13:39:49 UTC
Created attachment 156964 [details]
Empty field

(In reply to Regina Henschel from comment #9)
> Width should be zero, but it should have a field shading...

Exactly as it is implemented.
Comment 12 Regina Henschel 2020-01-06 15:19:22 UTC
Created attachment 156968 [details]
screenshot of input fields

(In reply to Heiko Tietze from comment #11)
> Exactly as it is implemented.

For me, there is no field shading. I use Version: 6.3.2.2 (x64)
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

OpenGL is disabled.

In file it is an empty element <text:text-input text:description="Enter Text"/>
With content it is e.g <text:text-input text:description="Enter Text">inside</text:text-input>
Comment 13 Heiko Tietze 2020-01-07 12:23:56 UTC
Works for me with

Version: 6.2.8.2
Build ID: 6.2.8-3
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: kde5; 
Locale: de-DE (en_US.UTF-8); UI-Language: en-US
Calc: threaded
and
Version: 6.5.0.0.alpha0+
Build ID: ecb5130e16898c0d2485e99564c57882b5ef25b0
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

so likely a Windows issue. Let's treat it as an ordinary bug.
Comment 14 sdc.blanco 2020-01-07 12:41:34 UTC
Modified summary to be more precise.

1.  Only "Input Field" with no value becomes "invisible" (i.e. no shading, no toggle with Ctrl+F8 - (happens with Input Fields made with both "Variable" and "User Field")

2.  If there is a value in the Input Field, then shading is shown (and toggled with Ctrl-F8)

3. If the value for the Input field is deleted  (e.g., double-click on Input Field, use Review Fields dialog to remove text), then "invisible"

4.  There is No Problem with a "valueless" User Field or a valueless Variable (e.g., in Text Format with no value) (i.e., shading is shown).
Comment 15 QA Administrators 2022-01-07 03:44:20 UTC Comment hidden (obsolete)
Comment 16 sdc.blanco 2022-01-07 13:05:33 UTC
(In reply to sdc.blanco from comment #14)
> 1.  Only "Input Field" with no value becomes "invisible" (i.e. no shading,
> no toggle with Ctrl+F8 - (happens with Input Fields made with both
> "Variable" and "User Field")
Ctrl+F8 toggle now shows the empty input field, so closing as WORKSFORME

Tested with:

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win