Download it now!
Bug 129779 - crash when resizing font of a Text box on Draw canvas with Character dialog
Summary: crash when resizing font of a Text box on Draw canvas with Character dialog
Status: RESOLVED DUPLICATE of bug 129712
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.4.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-01-04 05:16 UTC by V Stuart Foote
Modified: 2020-01-04 15:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
WinDbg 64 stack trace & analysis for crashing Draw Text box font resize (9.41 KB, text/plain)
2020-01-04 05:19 UTC, V Stuart Foote
Details
process stack trace for crash Draw shell (23.63 KB, text/plain)
2020-01-04 05:25 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2020-01-04 05:16:49 UTC
On Windows 10 Home 64-bit en-US with
Version: 6.4.0.1 (x64)
Build ID: 1b6477b31f0334bd8620a96f0aeeb449b587be9f
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

STR:

1. open new Draw canvas
2. draw a couple of Shapes
3. add a Text box with a line of text
4. select text in text box
5. context menu and select Character... dialog
6. change font size for selected text
7. OK out of the dialog

Crash

Attached to WinDbg64 with recent git pull for source.

An !Analyze -v reports issue:

FAULTING_SOURCE_FILE:  c:\cygwin64\home\buildslave\source\libo-core\include\editeng\outliner.hxx

FAULTING_SOURCE_LINE_NUMBER:  207

FAULTING_SOURCE_CODE:  
   203: 
   204: public:
   205:                 OutlinerView( Outliner* pOut, vcl::Window* pWindow );
   206:                 ~OutlinerView();
>  207: 
   208:     EditView&   GetEditView() const { return *pEditView; }
   209: 
   210:     void        Scroll( long nHorzScroll, long nVertScroll );
   211: 
   212:     void        Paint( const tools::Rectangle& rRect, OutputDevice* pTargetDevice = nullptr );


=-ref-=

Breakpad uploads...

http://crashreport.libreoffice.org/stats/crash_details/5be1e66a-4449-4ae8-a77d-23876bae1474

http://crashreport.libreoffice.org/stats/crash_details/55396ef7-fecd-4f07-9b47-b0afd32cc35f
Comment 1 V Stuart Foote 2020-01-04 05:19:24 UTC
Created attachment 156923 [details]
WinDbg 64 stack trace & analysis for crashing Draw Text box font resize
Comment 2 V Stuart Foote 2020-01-04 05:25:59 UTC
Created attachment 156924 [details]
process stack trace for crash Draw shell
Comment 3 V Stuart Foote 2020-01-04 05:37:38 UTC
STR also crashing recent master/6.5.0 build
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 444f0d256957544d26b9af9a0898364e829df1b5
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

no affect with changing rendering, default, OpenGL, Skia
Comment 4 V Stuart Foote 2020-01-04 05:45:45 UTC
Does not crash if the font resize after selection is done from the Sidebar Properties deck, or from the Character... dialog launched from main menu Format -> Character.  

Just crashes from the Character dialog _when launched from Context menu_ after selection.
Comment 5 Dagmara 2020-01-04 12:54:45 UTC
I cannot confirm the bug causing a crash on both tested versions:

Version: 6.5.0.0.alpha0+ (x64)
Build ID: c97f9af5e47ea234ad709a1f66c1e8ed20640066
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: CL
and 
Version: 6.3.4.2 (x64)
Build ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded

resizing font size from context menu works correctly for me.
Comment 6 Roman Kuznetsov 2020-01-04 13:07:37 UTC
V Stuart Foote, can you test it in latest master from 04.01.20 or more new. Possibly it was fixed by Mike K. for bug 129712
Comment 7 V Stuart Foote 2020-01-04 15:28:17 UTC
@Roman, thanks for catching that. Yes fixed with 2020-01-04 TB77 build

Version: 6.5.0.0.alpha0+ (x64)
Build ID: c97f9af5e47ea234ad709a1f66c1e8ed20640066
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

backport for 6.4.0 is https://gerrit.libreoffice.org/c/core/+/86101 is up for review.

*** This bug has been marked as a duplicate of bug 129712 ***