Download it now!
Bug 130028 - TRACK CHANGES: Writer - Changes are not tracked for Format->Text menu capitalization edits (comment #14)
Summary: TRACK CHANGES: Writer - Changes are not tracked for Format->Text menu capital...
Status: RESOLVED DUPLICATE of bug 109266
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2020-01-16 01:36 UTC by haim kilov
Modified: 2020-04-06 14:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
track changes does NOT show the change for test1 (11.16 KB, image/png)
2020-02-16 00:05 UTC, haim kilov
Details
Show track changes in LO 7.0 works (46.39 KB, image/png)
2020-02-16 00:11 UTC, eisa01
Details
"show track changes" is "on" (136.65 KB, image/png)
2020-02-16 00:32 UTC, haim kilov
Details
Track changes works in 6.3.1 (396.43 KB, image/png)
2020-02-16 11:59 UTC, eisa01
Details
Track changes does not show any changes, 6.4.0.3 (145.29 KB, image/png)
2020-02-16 19:00 UTC, haim kilov
Details
Persists in safe mode (174.61 KB, image/png)
2020-02-18 18:29 UTC, haim kilov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description haim kilov 2020-01-16 01:36:57 UTC
1. Create a two-word file ("test1 test2")
2. Save it and close.
3. Open this file.
4. Track changes "ON".
5. Select the first word.
6. Format -> test -> change case -> uppercase.
7. The case is changed, but the changes are not visible.
8. Select the second word.
9. Manually replace it with "TEST2".
10. The case is changed, and the changes are visible.
Comment 1 Alex Thurgood 2020-01-29 09:05:43 UTC
No repro in 

Version: 7.0.0.0.alpha0+
Build ID: 9a2fc64b49b4a3067ba78648e3fcc73390717c80
CPU threads: 4; OS: Mac OS X 10.15.2; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded

with a Calc test document.
Irrespective of the use of UPPER or a manual typed ALLCAPS change, both changes are indicated by a comment in the correspondingly changed cell.

with a Writer document, I can however confirm the reported buggy behaviour.
Comment 2 Alex Thurgood 2020-01-29 09:06:21 UTC Comment hidden (obsolete)
Comment 3 eisa01 2020-02-15 23:31:31 UTC
I'm not understanding this bug. The behavior is identical to Word as far as I can tell?

Track changes shows the change.

test1: Since the format has changed, the whole thing word shows up in the new format and an indication on the left that something has changed. If I hover over with my mouse, it will say the format has changed

test2: If I read it correctly, step 9 is to manually type TEST2, which is then deleting the former test2 and we get to see the striked out test2 as well

Is this what you are also seeing?

This would then not be a bug. Setting as NEEDINFO for now
Comment 4 haim kilov 2020-02-16 00:05:10 UTC
Created attachment 157907 [details]
track changes does NOT show the change for test1

For test1, after I change the case of this single word to UPPERCASE, there is no indication on the left at all.
Comment 5 eisa01 2020-02-16 00:11:49 UTC
Created attachment 157908 [details]
Show track changes in LO 7.0 works

Do you have "show track changes" on in the "track changes toolbar"?

Can you also post the version info in the About window?
Comment 6 haim kilov 2020-02-16 00:32:43 UTC
Created attachment 157909 [details]
"show track changes" is "on"

The attachment shows that "Change Case" was the most recent action (top left corner) and that "Track Changes" for "Record" and "Show" is "On".

LO 6.3.1.2
Comment 7 eisa01 2020-02-16 11:58:38 UTC Comment hidden (obsolete)
Comment 8 eisa01 2020-02-16 11:59:18 UTC Comment hidden (obsolete)
Comment 9 haim kilov 2020-02-16 19:00:05 UTC
Created attachment 157929 [details]
Track changes does not show any changes, 6.4.0.3

Track changes does not show any changes for test1 in 

Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; VCL: osx; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

"manage" does not show any changes either
Comment 10 eisa01 2020-02-16 22:04:09 UTC
Strange, if "manage" doesn't show anything, then there's no recorded changes.

Are you 100% you put on record track changes before testing?

Otherwise I see you are on a old macOS version

Alex, how did you confirm this previously? Is it like comment #3 and comment #5 ?
Comment 11 Alex Thurgood 2020-02-18 10:28:49 UTC
No repro for me in Writer anymore with LO6400beta1

1) Create new Writer document
2) Type in a few single word text strings and enter paragraph returns
3) Save document
4) Activate change tracking (Edit > Track changes)
5) Select one word (double mouse click)
6) Enter context menu (left mouse button click)
7) Select "Character" to open character properties dialog.
8) Select Character Effects tab, choose Allcaps in the Case dropdown menu. click on OK
9) Notice how the change is tracked and displayed (default brown/beige colour).

WFM
Comment 12 Xisco Faulí 2020-02-18 11:53:26 UTC Comment hidden (obsolete)
Comment 13 haim kilov 2020-02-18 18:29:43 UTC
Created attachment 157987 [details]
Persists in safe mode

As requested, I reset my user profile and retested. The bug persists.

I selected the word "One" (double mouse click), then did Formst-> Text-> Change Case -> UPPERCASE. See the result.

HOWEVER, when I start from scratch and select "Character", "Effects", "Case", "Capitals", the Track Changes does work.
Comment 14 eisa01 2020-02-18 20:29:12 UTC
Ah, that explains it, I can replicate it.

None of the text capitalization functions are tracked if you go through the Format-> Text menu
(Upper case, lower case, cycle case, sentence case, capital every case, toggle case)

Also occurs on Windows.

LO 3.3 on Mac crashes when I try to replicate it there

Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 15 eisa01 2020-04-02 20:11:20 UTC
This has not been tested to occur on 3.3, so resetting version
Comment 16 NISZ LibreOffice Team 2020-04-06 14:22:49 UTC

*** This bug has been marked as a duplicate of bug 109266 ***