Download it now!
Bug 130039 - LibreOffice Writer: Inserting table into table causes format deletion
Summary: LibreOffice Writer: Inserting table into table causes format deletion
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables-Nested
  Show dependency treegraph
 
Reported: 2020-01-16 18:19 UTC by Steven Lannoo
Modified: 2020-05-10 13:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
1st screenshot (before problem) (45.32 KB, image/png)
2020-01-16 18:20 UTC, Steven Lannoo
Details
2nd screenshot (problem) (45.04 KB, image/png)
2020-01-16 18:21 UTC, Steven Lannoo
Details
The document before the problem occurs (16.38 KB, application/vnd.oasis.opendocument.text)
2020-01-17 18:49 UTC, Steven Lannoo
Details
The document after the problem occurs (16.07 KB, application/vnd.oasis.opendocument.text)
2020-01-17 18:49 UTC, Steven Lannoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steven Lannoo 2020-01-16 18:19:14 UTC
Description:
All formats reset after inserting a table into a table (see screenshots below)

Screenshots: https://imgur.com/a/QyQlwJN

Key words: Editing, formatting, table

Steps to Reproduce:
1. Insert table
2. Change table format
3. Insert table into table

Actual Results:
Formats reset

Expected Results:
Formats should remain


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Comment 1 Steven Lannoo 2020-01-16 18:20:52 UTC
Created attachment 157197 [details]
1st screenshot (before problem)
Comment 2 Steven Lannoo 2020-01-16 18:21:29 UTC
Created attachment 157198 [details]
2nd screenshot (problem)
Comment 3 Steven Lannoo 2020-01-16 18:42:50 UTC
Edit: copying and pasting a table from another document doesn't reset formats
Comment 4 Dieter 2020-01-17 12:24:29 UTC
Steven, thanks for reporting the bug. Comparing 1st and 2nd screenshot, i can't see a table in a table, but a new table in a document. Is it possible to attach both documents (only the first side)? This would make it easier to reproduce the bug.

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 5 Steven Lannoo 2020-01-17 18:49:10 UTC
Created attachment 157233 [details]
The document before the problem occurs

Hello Dieter Praas, 

I think you thought I didn't insert a table into a table because there might be a better way to format a document the way I do. If so, I don't know what it is. The point is that I use tables as an easy way to format documents, for instance, to align everything properly, or to create the grey borders on the top, the left side and the bottom of the document that you can see. The thing is that when I do this, I have to insert a table into a table, since the page itself is a table, and so on. But when I do, the formats I applied beforhand reset, hence erasing all the parameters of the formerly designed tables, making them look basic, so to speak (as though I did not format them whatsoever), which is not the purpose of what I intended to do in the first place. 

I made a first copy of the document in question, which I kept formatting, unfortunately having had to redo all the table formatting of the first tables I made in the document, which you will find attached here. 
You will also find a second copy of the document, in which I just inserted a new table below the last one I made (which is also inside a table). 

Many thanks, 

Steven Lannoo
Comment 6 Steven Lannoo 2020-01-17 18:49:47 UTC
Created attachment 157234 [details]
The document after the problem occurs
Comment 7 Buovjaga 2020-05-10 13:21:39 UTC
(In reply to Steven Lannoo from comment #5)
> Created attachment 157233 [details]
> The document before the problem occurs

I opened this and inserted a new table. The outer cells of the parent table keep their gray colour. Both with Win and Linux. I also saved and reloaded to be sure.

Please test with version 6.4.x

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Arch Linux 64-bit
Version: 6.4.3.2
Build ID: 6.4.3-1
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded