Download it now!
Bug 130075 - EDITING - While pasting data in a table, selecting "Next" makes Base crash
Summary: EDITING - While pasting data in a table, selecting "Next" makes Base crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.5.0 target:6.4.0
Keywords: bibisected, bisected, haveBacktrace
Depends on:
Blocks:
 
Reported: 2020-01-18 20:24 UTC by Simon Stuardo
Modified: 2020-01-21 16:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sal3.dll"]


Attachments
ODB test file to reproduce error (2.80 KB, application/vnd.sun.xml.base)
2020-01-19 17:13 UTC, Simon Stuardo
Details
ODS test file to reproduce error (8.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-01-19 17:14 UTC, Simon Stuardo
Details
steps to reproduce error - in images (71.77 KB, application/x-zip-compressed)
2020-01-19 17:22 UTC, Simon Stuardo
Details
bt with debug symbols (18.65 KB, text/plain)
2020-01-19 20:19 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Stuardo 2020-01-18 20:24:11 UTC
Steps to reproduce:
1. Copy data from calc, paste to an already existent base table.
2. When dialog "copiar tabla" appears (I'm guessing name is "copy table" in english), press "Siguiente >" ("Next >" I guess)
3. Crash!


I followed the rules, i.e., source data in calc has column headers. Also column names and types are the same in source (calc) and destination (base) tables
Tried in both firebird db and HSQLDB. Tried with several columns down to just 1 column of data pasted. Tried with just "paste" and "paste special", always with the same result.

This bug was filed from the crash reporting server and is br-720d91a9-8640-42ab-bbd5-88c571e8e167.
=========================================
Comment 1 Julien Nabet 2020-01-18 21:50:01 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Could you attach a minimal ods file + odb file (hsqldb) in a zip so we can try to reproduce this?
Comment 2 Simon Stuardo 2020-01-19 17:13:26 UTC
Created attachment 157252 [details]
ODB test file to reproduce error
Comment 3 Simon Stuardo 2020-01-19 17:14:30 UTC
Created attachment 157253 [details]
ODS test file to reproduce error
Comment 4 Simon Stuardo 2020-01-19 17:22:29 UTC
Created attachment 157254 [details]
steps to reproduce error - in images
Comment 5 Simon Stuardo 2020-01-19 20:00:52 UTC
Added the files you requested.
Also tried failsafe mode on and off, both ways I got the error.
Finally rolled back to LO 6.3.4.2, so I can work
Comment 6 Julien Nabet 2020-01-19 20:14:39 UTC
Thank you for your very detailed feedback!

On pc Debian x86-64 with master sources updated today, I could reproduce this with gen rendering (not with gtk3).
Comment 7 Julien Nabet 2020-01-19 20:19:15 UTC
Created attachment 157255 [details]
bt with debug symbols

Assertion but in non debug mode, it would crash the line after:
   1662 void SvTreeListBox::SetEntryText(SvTreeListEntry* pEntry, const OUString& rStr)
   1663 {
   1664     SvLBoxString* pItem = static_cast<SvLBoxString*>(pEntry->GetFirstItem(SvLBoxItemType::String));
   1665     assert(pItem);
   1666     pItem->SetText(rStr);
See https://opengrok.libreoffice.org/xref/core/vcl/source/treelist/treelistbox.cxx?r=a62a139c#1662
Comment 8 Julien Nabet 2020-01-19 20:20:33 UTC
Caolán: thought you might be interested in this one since it concerns vcl/gen part and I know you're doing some refactoring.
(of course, don't hesitate to uncc yourself if no time, not feel like, ...)
Comment 9 Xisco Faulí 2020-01-20 09:10:28 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8c66efa030e98cfdf5da20be368566d64e43c5d1

author	Caolán McNamara <caolanm@redhat.com>	2019-09-05 12:22:38 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-09-12 20:28:14 +0200
commit	8c66efa030e98cfdf5da20be368566d64e43c5d1 (patch)
tree	88c9fb335349fd1b7b285d46108e5d41a3c9aac4
parent	8150219824a1d08c4a22fd8bb7cc63fe2aa88074 (diff)
weld OCopyTableWizard cluster

Bisected with: bibisect-linux64-6.4
 
Adding Cc: to Caolán McNamara
Comment 10 Commit Notification 2020-01-20 20:16:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6b6484d25b63fe68e94f60ca8d6fb2b0b039bdfb

Resolves: tdf#130075 have to specify which column is the text column

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2020-01-20 20:20:36 UTC
fixed in master, backport to 6-4 in gerrit
Comment 12 Xisco Faulí 2020-01-21 08:22:22 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: b92293b3943423324064a8513c2e114d18817179
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 13 Commit Notification 2020-01-21 08:24:26 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/97928a862bd7e74955dbc59732be9e43f1a2d42a

Resolves: tdf#130075 have to specify which column is the text column

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-01-21 16:49:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-0":

https://git.libreoffice.org/core/commit/ef8d6f0b7bd8455a9dfbfb9dcf7b02fa5fc80d91

Resolves: tdf#130075 have to specify which column is the text column

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.