Bug 130098 - Is Alt-F12 supposed to be a protected keyboard shortcut? Can change mapping to Alt-F12 -- but change does not appear in menu
Summary: Is Alt-F12 supposed to be a protected keyboard shortcut? Can change mapping ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevAdvice
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2020-01-20 22:31 UTC by sdc.blanco
Modified: 2021-01-24 10:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The Customize dialog with Options (143.95 KB, image/png)
2021-01-13 23:09 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-01-20 22:31:53 UTC
Make a keyboard shortcut, where the Customize dialog is mapped to Alt-F12

1. Tools menu
  (notice that Options has Alt-F12 as shortcut)
2. Choose Customize (in Tools Menu), then Keyboard tab  
3. Select Alt-F12 (in Shortcut Keys)  (nothing is mapped to this key combination)
4. Select Options (Category) and Customize (Function)
5. Press "Modify", then OK
6. Open Tools Menu

Actual result:  
  - Tools>Customize does not show Alt-F12 as shortcut (not as expected)
  - Tools>Options shows Alt-F12 as shortcut (not as expected)

7. Press Alt-F12

  - Customize dialog box opens  (as expected)

Alt-F12 is not mentioned in the help pages -- so do not know if it has a special status.
Comment 1 Gabor Kelemen (allotropia) 2021-01-13 23:09:05 UTC
Created attachment 168865 [details]
The Customize dialog with Options

The Alt+F12 binding is a global one, so you have to select the top right LibreOffice radio button to see it and to change it.

This is not a bug we just have a clumsy dialog here.
Comment 2 sdc.blanco 2021-01-14 02:46:07 UTC
Thanks for explanation Gabor! 

Just looked to see if help pages could be improved.  
Not so clear where.  Maybe:

https://help.libreoffice.org/7.2/en-US/text/shared/01/06140200.html

To assign a key for all applications, choose the %PRODUCTNAME radio button in the top right corner. Common shortcuts, such as Ctrl+X and Ctrl+P, are found here. 

<note>
Keys assigned for a particular %PRODUCTNAME application override the shortcut setting in %PRODUCTNAME.
</note>


Meanwhile -- in further testing -- I think I can see better what motivated the original report.  I think there may be a bug with "updating" of the shortcut keys in the menus. (which I misinterpreted as a "protected" key).

If you are willing, please try these two simple tests to illustrate the problem:

Test 1

1. Assign "Customize" to Alt-F11, then confirm that Alt-F11 appears in Tools menu.
2. Use Alt-F11 to open Customize dialog again and assign Alt-F9 to "Customize"  (now Alt-F9 appears in Tools menu).
3. Use Alt-F11 (or Alt-F9) to open Customize again and Delete Alt-F9

Actual:  no shortcut shown in menu
Expected:  Alt-F11
(same thing happens -- no shortcut shown -- if you delete Alt-F11)

Test 2

1. Assign Options to Alt-F12 (in Writer, shows Alt-F12 in Tools menu)
2. Assign Options to Alt-F9  (see in Tools menu that Options is now Alt-F9)
3. Assign Customize to Alt-F9  (see that Customize and Options are Alt-F9)
(expected Options to show Alt-F12 -- which does actually work).
Comment 3 sdc.blanco 2021-01-24 10:13:26 UTC
 (In reply to sdc.blanco from comment #2)
> If you are willing, please try these two simple tests to illustrate the
> problem:
Reported in bug 139879