Download it now!
Bug 130126 - svg file (created with matplotlib) not displaying correctly in Impress
Summary: svg file (created with matplotlib) not displaying correctly in Impress
Status: RESOLVED DUPLICATE of bug 97539
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2020-01-22 16:26 UTC by andrea.pogliani
Modified: 2020-01-23 08:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example SVG (28.86 KB, image/svg+xml)
2020-01-22 20:04 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrea.pogliani 2020-01-22 16:26:12 UTC
Description:
Hi. I am trying to import a .svg plot I made with matplotlib in an Impress presentation. The plot is a loglog plot. The issue is that in the displayed plot the line goes beyond the axis, which it shouldn't. It seemed to be a matplotlib issue with librsvg, but they say they solved it (https://github.com/matplotlib/matplotlib/issues/4341) so I was wondering if anybody has encountered this kind of probems in libreoffice. I am using: macos 10.13.6, libreoffice 6.3.4.2, matplotlib 3.1.1. The file is displayed correctly in a browser.

Steps to Reproduce:
1. Produce a loglog plot with matplotlib and save it to a svg file
2. import it in impress

Actual Results:
The line of the plot goes beyond the axis line, till the border of the image. 

Expected Results:
The plot should be rendered as it should be.


Reproducible: Always


User Profile Reset: No



Additional Info:
here is a link to the svg file. https://pastebin.com/HrPnQ5W8 
You can download it and try to import in a browser and in impress to see the difference.
Comment 1 Telesto 2020-01-22 20:03:52 UTC
Repro with
Version: 6.5.0.0.alpha0+ (x64)
Build ID: ce685f64f38551e7984155783c9c7660d986abf6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-US (nl_NL); UI-Language: en-US
Calc: CL

and with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

and with
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5

and with
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

but not with
AOO413m1(Build:9783)  -  Rev. 1761381
2016-09-29 02:39:19
Comment 2 Telesto 2020-01-22 20:04:17 UTC
Created attachment 157340 [details]
Example SVG
Comment 3 V Stuart Foote 2020-01-22 20:32:37 UTC
Isn't the clip-path issue here a dupe of bug 97539
Comment 4 Xisco Faulí 2020-01-23 08:46:59 UTC
The problem is in

 <defs>
  <clipPath id="p42286448d1">
   <rect height="266.112" width="357.12" x="57.6" y="41.472"/>
  </clipPath>
 </defs>

Closing as dupe of bug 97539

*** This bug has been marked as a duplicate of bug 97539 ***
Comment 5 andrea.pogliani 2020-01-23 08:56:46 UTC
Thank you for working on this!