Download it now!
Bug 130152 - inside a table, comment option missing in context menu
Summary: inside a table, comment option missing in context menu
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0
Keywords: needsUXEval
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2020-01-23 20:09 UTC by dfbugs
Modified: 2020-03-13 08:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dfbugs 2020-01-23 20:09:00 UTC
To reproduce: Create a writer Document. Insert some text. Insert a table.

Actual behavior:
When right clicking outside the table, there's an option "Comment" to add a comment.
When right clicking inside the table, this is lacking. (Ctrl-Alt-C does work, however.)

Expected behavior:
Be able to add a comment via the context menu inside a table, as well.
Comment 1 Dieter 2020-01-23 20:21:59 UTC
I confirm it with

Version: 6.5.0.0.alpha0+ (x64)
Build ID: 350d25da375f221edfa37309324ce3c68cf297ef
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Second optiona, that is missing in table context menu is "Page Style". Since you can customize context menu, I'm not sure, if table context menu should get more options by default.

cc: Design Team
Comment 2 Heiko Tietze 2020-01-24 08:53:50 UTC
On the one hand, we should keep the menus simple and easy to access. Meaning, as few items as possible. On the other hand, consistency makes sense so you can easily pick the same command at the same position. 

I'm a bit split in this particular case but tend to agree with the request. Andreas, what do you think?
Comment 3 andreas_k 2020-03-03 15:57:38 UTC
will add .uno:InsertAnnotation to table context menu. 

Page Dialog is something for the text/page context menu. The table context menu is already very long and ordinary you should have something more than an table in an writer document.
Comment 4 Commit Notification 2020-03-03 21:19:09 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ce7bbf421d97cb87db1e9350365b73904d5e26de

tdf#130152 Writer Table context menu add Comment command

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Dieter 2020-03-13 08:46:27 UTC
Verified with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: c63148ba139bd6b9ae7a0f9e24e51f29e5370963
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Andreas, thanks for fixing it!