Download it now!
Bug 130161 - Object list in catalog doesn't refresh after adding a Module or dialog
Summary: Object list in catalog doesn't refresh after adding a Module or dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.2 target:6.3.6
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-01-24 01:49 UTC by Simon Stuardo
Modified: 2020-02-13 08:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast from 6-4 (576.08 KB, video/webm)
2020-02-10 16:22 UTC, Caolán McNamara
Details
printscreen from LO 7 (37.96 KB, image/png)
2020-02-10 16:48 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Stuardo 2020-01-24 01:49:39 UTC
Description:
When you are in the dialog or macros organizer in LibreOffice Basic, and you add either a module or a dialog, Catalog object doesn't refresh.
You can close the IDE and reopen it, and it is ok though.

Steps to Reproduce:
1. Open macros organizer
2. Add a module or dialog (haven't tried with libraries, I guess it's the same)
3. Look at the objects catalog pane ("Catalogo de objetos" in my language)

Actual Results:
Doesn't update

Expected Results:
Update automatically to show the new catalog object


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 raal 2020-02-09 09:57:07 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

bibisect-linux-64-6.4
1422df3e1338ce034c616dfbc3248b0fb3436c7f is the first bad commit
commit 1422df3e1338ce034c616dfbc3248b0fb3436c7f
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Jun 13 02:07:30 2019 +0200

    source sha:ad1cbee2ffc7b3c10cad6fd69f5e4b523ac4027c

author	Caolán McNamara <caolanm@redhat.com>	2019-06-07 15:42:52 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2019-06-12 21:44:39 +0200
commit	ad1cbee2ffc7b3c10cad6fd69f5e4b523ac4027c (patch)
tree	deb0368f573238325c4e30bf1b932e6b3e0c05a2
parent	0e27158c4f6a6a7676a77afb6b37dd30b3f6d100 (diff)
weld OrganizeDialog
Comment 2 Xisco Faulí 2020-02-10 14:59:54 UTC
Moving to NEW
Comment 3 Caolán McNamara 2020-02-10 16:22:56 UTC
Created attachment 157774 [details]
screencast from 6-4

am I using the wrong thing ?, it seems to work for me when I try it
Comment 4 raal 2020-02-10 16:48:23 UTC
Created attachment 157775 [details]
printscreen from LO 7

Hello Caolan, please click on Untitled 1, then click New, confirm dialog.
Comment 5 Commit Notification 2020-02-11 13:56:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b97af2719c739649d86a8ec1cc1d0c2d38b26697

Related: tdf#130161 invalid iterator used in BrowseMode::Subs case

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2020-02-11 14:28:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/020ee2fcc1a40415dca8e974cf30834667f55036

Related: tdf#130161 invalid iterator used in BrowseMode::Subs case

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-02-11 14:29:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/185915aabde2418d99d16d6b7d9efc39f5cc0fe6

Related: tdf#130161 invalid iterator used in BrowseMode::Subs case

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Caolán McNamara 2020-02-12 14:58:22 UTC
I can't find evidence that document dialog/modules created in the organizer not appearing is a recent regression. If I use the bisect repor and use commit 0e27158c4f6a6a7676a77afb6b37dd30b3f6d100 which is before the indicated commit then it still fails to automatically appear.

But https://cgit.freedesktop.org/libreoffice/core/commit/?id=44861f2435a0c487d4fb5b196f7e4fe7f9569396

commit 44861f2435a0c487d4fb5b196f7e4fe7f9569396
Author: Uray M. János <uray.janos@gmail.com>
Date:   Fri Aug 17 07:29:20 2012 +0200

did change the UpdateObjectCatalog from happening on every MarkDocumentModified to only happening on rDocument.isApplication instead of all documents which seems to be the problem
Comment 9 Caolán McNamara 2020-02-12 15:58:26 UTC
If I understand the problem correctly it can be worked around by collapsing the document macro tree in the organizer and re-expanding it after the document modules/dialogs are added
Comment 10 Commit Notification 2020-02-13 08:48:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9fd9da5739f5a99330af5601cd0a3a257f9dc529

tdf#130161 adding a document dialog or modules doesn't update catalog

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-02-13 08:48:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7c81a8f5a12b754efd06681e017066008f00afa6

tdf#130161 detect if a node already had an expansion attempt

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-02-13 08:49:29 UTC
that seems to work in master now