Bug 130176 - FILESAVE chart:interpolation "stepped" produces invalid ODF 1.2, both strict and extended
Summary: FILESAVE chart:interpolation "stepped" produces invalid ODF 1.2, both strict ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:7.0.0 odf odf_validation
Keywords:
Depends on:
Blocks: ODF-export-invalid
  Show dependency treegraph
 
Reported: 2020-01-24 15:51 UTC by Regina Henschel
Modified: 2020-07-31 21:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document to test chart:interpolation (27.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-01-24 15:51 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2020-01-24 15:51:20 UTC
Created attachment 157406 [details]
Document to test chart:interpolation

The attached file is invalid "ODF 1.2 extended" and saving in "ODF 1.2" will result in invalid "ODF 1.2" too, because it uses in the chart:interpolation attribute the values "step-start", "step-end", "step-center-x" and "step-center-y". Those do not exist in ODF 1.2

The values will be included in "ODF 1.3".

Proposal:
Make LO conform to "ODF 1.2" and do not write these interpolation types. Add a release note to inform the user, that he has to use "ODF 1.3" to get these kind of interpolation in strict mode.

Do not correct the error in saving in "ODF 1.2 extended". To get this corrected, the attribute needs to be put in namespace loext. The current versions need to be changed to support the attribute in this namespace. And then, when enough users actually use the patched version, then LO can write the attribute in its own namespace. But that will be at a time, when LO is already writing ODF 1.3. And there these values are allowed.

Validity can be checked with https://odfvalidator.org/
Comment 1 Michael Stahl (CIB) 2020-02-18 09:51:29 UTC
proposal sounds reasonable :)
Comment 2 Regina Henschel 2020-05-25 13:56:19 UTC
I see it fixed in Version: 7.0.0.0.alpha1+ (x64)
Build ID: 0e5e935deb0527c64865cfcc53a0421e56b74b6f
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL

I have added a note to https://wiki.documentfoundation.org/ReleaseNotes/7.0

@Michael: Can you please review my note and perhaps add in this bug report the id of the commit, which fixes the issue?
Comment 3 Michael Stahl (CIB) 2020-05-25 14:05:49 UTC
was fixed on master by:

commit 58c013516694b1083abdbc76300ed003f6a456c5
Author:     Michael Stahl <Michael.Stahl@cib.de>
AuthorDate: Tue May 12 14:32:05 2020 +0200
Commit:     Michael Stahl <michael.stahl@cib.de>
CommitDate: Tue May 19 10:21:44 2020 +0200

    xmloff: ODF export: additional ODF 1.3 chart features
    
    * OFFICE-3662 chart:interpolation additional values
    * OFFICE-3958 chart regression curve: polynomial
    * OFFICE-3959 chart regression curve: moving-average
    
    None of these are exported in ODF 1.2 extended because they require
    additional values for standard attributes, which isn't valid.
    
    Change-Id: I920cc44dbde46687b570c1296c7d8926f0a1a9c6
    Reviewed-on: https://gerrit.libreoffice.org/c/core/+/94064
    Tested-by: Jenkins
    Reviewed-by: Michael Stahl <michael.stahl@cib.de>


i need to add ODF 1.3 support to release notes...