Bug 130218 - FILEOPEN DOCX Hanging indent in table is not ignored if it would hide the paragraph
Summary: FILEOPEN DOCX Hanging indent in table is not ignored if it would hide the par...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords:
: 130217 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2020-01-27 12:35 UTC by NISZ LibreOffice Team
Modified: 2020-06-25 08:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Word (25.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-01-27 12:36 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer (82.47 KB, image/png)
2020-01-27 12:37 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-01-27 12:35:50 UTC
Description:
Attached table is reduced (and extended) from attachment #130321 [details] of bug #105261.

Originally it contained a table with some centered paragraphs (“TIPOLOGIA CONTRATTO”) that had 3.75 cm hanging indent set. This is sort of ignored by Word, but Writer tries to display the paragraphs with this applied, causing only the ends of the words being visible.
Extending the test file with copies of the same paragraph, but changing the alignment to left, right and justified shows similar results with the left and justified aligned text being unreadable.
Copying the extended table and disabling the hanging indent gets the same appearance in Word as with the large hanging indent (so it has no visual effect).
This also appears correctly in Writer too.

Steps to Reproduce:
Open attached document in Word and Writer.

Actual Results:
The text in the first table is not entirely visible in case of left, centered and justified alignments. In case of right alignment its only visible by chance: switching to RTL direction in Writer hides that too.

Expected Results:
Extraneous hanging indent should be ignored in tables, so that text is visible like in Word.



Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2020-01-27 12:36:38 UTC
Created attachment 157451 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2020-01-27 12:37:11 UTC
Created attachment 157452 [details]
Screenshot of the original document side by side in Word and Writer
Comment 3 Timur 2020-01-27 12:40:01 UTC
*** Bug 130217 has been marked as a duplicate of this bug. ***
Comment 4 Dieter 2020-01-28 07:29:43 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded
Comment 5 Commit Notification 2020-06-23 10:21:21 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2eecf2b007a44c4e2ce2877af2c841875a70c282

tdf#130218 sw: show hanging indent in narrow cells

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2020-06-24 10:30:06 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: cb72269f93a20dd175dae3dcf30740c9931e7684
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!
Comment 7 Xisco Faulí 2020-06-24 10:31:14 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.19; Render: default; 

Locale: en-US (en_US.UTF-8)
Comment 8 László Németh 2020-06-24 10:46:15 UTC
(In reply to Xisco Faulí from co
> @László Németh, thanks for fixing this issue!!

@Xisco: thanks for verification and back-porting!
Comment 9 Commit Notification 2020-06-24 12:56:23 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d593fef07be33cf7999b191e0f4aa87e79e2845c

tdf#130218 sw: show hanging indent in narrow cells

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.