Bug 130255 - Saving a XLSX in shared mode adds white rectangles covering top left part of the sheet
Summary: Saving a XLSX in shared mode adds white rectangles covering top left part of ...
Status: RESOLVED DUPLICATE of bug 117274
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-29 12:08 UTC by Mike Kaganski
Modified: 2020-01-30 08:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
XLSX put in Shared (legacy) mode in Excel 2016 (21.56 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-01-29 12:08 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-01-29 12:08:03 UTC
Created attachment 157494 [details]
XLSX put in Shared (legacy) mode in Excel 2016

The attached file had been put to "shared workbook" state in Excel 2016. Opening it in Calc, and simply saving (keeping XLSX format) adds a white rectangle (in my testing, WxH ~ 26x50 cm) to the top left of the sheet.

Tested with Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 12; OS: Windows 10.0 Build 18363; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL

and with LibreOffice 3.3.0
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

(this is not inherited from OOo, since the latter couldn't save to XLSX).
Comment 2 m.a.riosv 2020-01-29 22:04:30 UTC
Confirmed
Version: 6.4.0.3 (x64)
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 4; OS: Windows 10.0 Build 19551; UI render: GL; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

At opening the file has three drawing objects with different names, after save and reopening the three objects has the same name, and the withe box appear.
Comment 3 NISZ LibreOffice Team 2020-01-30 08:33:27 UTC
This is because of the comment in B52, not the shared mode (which is lost on save anyways -> bug #100433). 
The Excel comments have text contents and a VML shape for positioning, and the broken export of this VML shape was fixed in bug #117274. 

Excel considered the LO-saved VML broken, and saved it as a separate, but virtually invisible shape (and created a new one for positioning the comment). This is the "Autoshape 2" in the example file.
Another save in LO <= 6.3 made this shape visible that's how the huge white rectangle was created.

If you double click in the Navigator on the "Autoshape 2" and press Del to delete it, the problem will no longer occur in 6.4 after save & reload.

The fix to bug #117274 stopped creating broken VML files, but does not remove the autoshapes stashed away by Excel - you can do that only manually.

*** This bug has been marked as a duplicate of bug 117274 ***