Bug 130268 - [Feature Request] Ability to set Persona (theme) on a per-application basis in LibreOffice
Summary: [Feature Request] Ability to set Persona (theme) on a per-application basis i...
Status: RESOLVED DUPLICATE of bug 121174
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: LibreOffice-Themes
  Show dependency treegraph
 
Reported: 2020-01-29 21:25 UTC by Darren John de Lima
Modified: 2020-02-19 09:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darren John de Lima 2020-01-29 21:25:01 UTC
LibreOffice contains Writer, Math, Calc, Base, Draw and Impress (and the "Home" application) . I would like to set a colour persona theme separately for each of those applications - e.g. MS Word-blue for Writer, Excel-green for Calc, Access-maroon for Base, yellow for Draw, gray for "Home", etc.

Currently, it is only possible to set a single persona colour for all of LibreOffice. Could you please implement the ability to set Personas/themes on a per-application basis? It would also be nice to import custom themes more easily (currently, one has to browse to obscure folders and replace the built-in themes).

I would thus be able to instantly tell which application I'm using in a multi-windowed view. It would also make transitioning from Microsoft products more comfortable.

Thank you for making a great product!
Comment 1 Heiko Tietze 2020-02-19 09:36:21 UTC
Plan is to have own themes and get rid of Mozilla's Persona. Anyway, the request has been done before.

*** This bug has been marked as a duplicate of bug 121174 ***