Bug 130275 - "Insert > Field > More Fields" dialog is too high/tall - the OK/Cancel buttons get hidden behind the bottom panel of 'gnome-panel'
Summary: "Insert > Field > More Fields" dialog is too high/tall - the OK/Cancel button...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Kevin Suo
URL:
Whiteboard: target:7.2.0 target:7.1.0.2
Keywords: patch
Depends on:
Blocks: GTK3-Dialog-High
  Show dependency treegraph
 
Reported: 2020-01-30 03:32 UTC by Jambunathan K
Modified: 2021-01-04 23:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The cancel/ok buttons are hidden behind the bottom panel of gnome-panel (103.57 KB, image/png)
2020-01-30 03:32 UTC, Jambunathan K
Details
Another full screenshot (75.83 KB, image/png)
2020-12-15 02:02 UTC, Kevin Suo
Details
a patch which works but need expert's revision (4.40 KB, patch)
2020-12-16 11:59 UTC, Kevin Suo
Details
Full screenshot with the patch applied (85.33 KB, image/png)
2020-12-16 12:01 UTC, Kevin Suo
Details
Screenshot with patch 1 applied (11.95 KB, image/png)
2020-12-18 12:34 UTC, Heiko Tietze
Details
Screenshot with patch 2 applied (22.19 KB, image/png)
2020-12-18 13:48 UTC, Heiko Tietze
Details
Screenshot with patch 2 applied #2 (12.18 KB, image/png)
2020-12-18 13:50 UTC, Heiko Tietze
Details
Ctrl + F2 now shows Close/Insert buttons (89.20 KB, image/png)
2020-12-31 07:30 UTC, Jambunathan K
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jambunathan K 2020-01-30 03:32:32 UTC
Created attachment 157519 [details]
The cancel/ok buttons are hidden behind the bottom panel of gnome-panel

Ctrl + F2 (i.e., insert More Fields) dialog:  The confirmation buttons get hidden behind the bottom panel of 'gnome-panel'.  See the attached screenshot.

~$ env | grep SESSION
SESSION_MANAGER=local/debian:@/tmp/.ICE-unix/1819,unix/debian:/tmp/.ICE-unix/1819
GNOME_DESKTOP_SESSION_ID=this-is-deprecated
DESKTOP_SESSION=gnome-flashback-metacity
XDG_SESSION_DESKTOP=gnome-flashback-metacity
XDG_SESSION_TYPE=x11
XDG_SESSION_CLASS=user
GDMSESSION=gnome-flashback-metacity
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus

~$ uname -a
Linux debian 5.4.0-2-amd64 #1 SMP Debian 5.4.8-1 (2020-01-05) x86_64 GNU/Linux

~$ dpkg -l | grep writer
ii  libreoffice-writer                    1:6.3.4-2                            amd64        office productivity suite -- word processor

Version: 6.3.4.2.0+
Build ID: 1:6.3.4-2
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-IN (en_IN.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Kevin Suo 2020-02-01 01:38:51 UTC
I reproduce this bug with
Version: 7.0.0.0.alpha0+
Build ID: 62640556cca53ffa160456441db38899d6f885d5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); UI-Language: en-US
Calc: threaded

OS: Fedora 31 X64, GNOME Shell 3.34.3.
Comment 2 Kevin Suo 2020-12-15 02:02:01 UTC
Created attachment 168177 [details]
Another full screenshot

Mesa Intel® HD Graphics 620 (KBL GT2)
1366*768 19:9 display
Acer laptop, Fedora 32 x11.
Comment 3 Kevin Suo 2020-12-16 11:57:12 UTC
I checked the .ui files and they seem to be with normal height. 
Then I tried to change the various places as shown in the attached patch file (e.g., "auto nHeight = m_xTypeLB->get_height_rows(XX)" in sw/source/ui/fldui/flddb.cxx etc). With this patch, this dialog becomes normal. Since I do not know the code and this seems to be related to "weld", I am adding Caolán to cc: would you please take a look?
Comment 4 Kevin Suo 2020-12-16 11:59:05 UTC
Created attachment 168224 [details]
a patch which works but need expert's revision
Comment 5 Kevin Suo 2020-12-16 12:01:20 UTC
Created attachment 168225 [details]
Full screenshot with the patch applied
Comment 6 Caolán McNamara 2020-12-17 12:32:01 UTC
wrt #4 setting the height to one row means they will take up the height of whatever else is the tallest element in the dialog. Nothing wrong with that, but there are other dialogs which contain just one of the pages you see in that dialog. e.g. in the fields dialog insert from Document a "page field, then right click the inserted field and select "edit fields" and a dialog with just one of the tabpages used is shown.

So the thing to test is to insert a field from each page of the insert, fields dialog and then right click and edit,fields each of them to gauge if the suggested change is bad for that case
Comment 7 Kevin Suo 2020-12-17 14:22:34 UTC
(In reply to Caolán McNamara from comment #6)

Thank you for the information. I tested and nothing bad for now.
Heiko: Would you also take a look of this?
Comment 8 Heiko Tietze 2020-12-18 08:42:52 UTC
(In reply to Kevin Suo from comment #7)
> (In reply to Caolán McNamara from comment #6)
> 
> Thank you for the information. I tested and nothing bad for now.
> Heiko: Would you also take a look of this?

Please submit the patch to Gerrit and add me as reviewer. I'll check locally.
Comment 9 Kevin Suo 2020-12-18 12:18:14 UTC
I've submitted the patch on gerrit: https://gerrit.libreoffice.org/c/core/+/107965
Comment 10 Heiko Tietze 2020-12-18 12:34:16 UTC
Created attachment 168292 [details]
Screenshot with patch 1 applied

Insert > Page Number, Edit Field => the list of formats has no minimum number of items.
Comment 11 Kevin Suo 2020-12-18 13:19:49 UTC
(In reply to Heiko Tietze from comment #10)
Same issue on database and some other tabs. Would you please test with patch set 3?
Comment 12 Heiko Tietze 2020-12-18 13:48:57 UTC
Created attachment 168297 [details]
Screenshot with patch 2 applied

More Fields > Document > Statistics => the Format list is too small now to avoid the horizontal scrollbar; not a big issue though.
Comment 13 Heiko Tietze 2020-12-18 13:50:16 UTC
Created attachment 168298 [details]
Screenshot with patch 2 applied #2

More Fields > DocInformation > Modified => that's a showstopper (also for Created)
Comment 14 Kevin Suo 2020-12-18 16:05:39 UTC
Heiko: could you test with the new patch set 4. I think it's much better now.
Thanks to Caolan for your code pointer to the UI file!
Comment 15 Commit Notification 2020-12-23 10:38:48 UTC
Kevin Suo committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8be0be8066f50e0ce660d40f121c7d7891f1bc49

tdf#130275: Fields dialog is too tall

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Jambunathan K 2020-12-24 04:33:13 UTC
(In reply to Commit Notification from comment #15)
> Kevin Suo committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> 8be0be8066f50e0ce660d40f121c7d7891f1bc49
> 
> tdf#130275: Fields dialog is too tall
> 
> It will be available in 7.2.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Thanks for the fix. 

(The soonest I can verify this fix is when Debian/Unstable starts shipping LibreOffice 7.2.0)
Comment 17 Kevin Suo 2020-12-24 08:59:09 UTC
> (The soonest I can verify this fix is when Debian/Unstable starts shipping LibreOffice 7.2.0)

I've already submitted a patch to cherry-pick this fix to 7.1 branch, but I think it may take some time before it is approved. As Heiko has commented, there may be regressions caused by this.

I see you are using Debian, so why not download a daily build and have a test?
Comment 18 Jambunathan K 2020-12-24 09:13:49 UTC
(In reply to Kevin Suo from comment #17)
> > (The soonest I can verify this fix is when Debian/Unstable starts shipping LibreOffice 7.2.0)
> 
> I've already submitted a patch to cherry-pick this fix to 7.1 branch, but I
> think it may take some time before it is approved. As Heiko has commented,
> there may be regressions caused by this.
> 
> I see you are using Debian, so why not download a daily build and have a
> test?

I wasn't aware that the daily builds are available for LibreOffice.  I am willing to test this fix on my machine.

Could you please look at the timestamp and check if the fix is available in this build

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF/2020-12-22_10.13.25/master~2020-12-22_10.13.25_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.tar.gz

Linux-rpm_deb-x86_64@86-TDF (deb) 	2020-12-22 15:44:11 	8ba7c3b
Comment 19 Kevin Suo 2020-12-24 09:24:27 UTC
(In reply to Jambunathan K from comment #18)

The buildinfo.txt file of that daily build says that this daily build was based on:
8ba7c3b63f87a443139c9104b02e3864dd31daf9

and you can see the commit fixing this bug is within this list:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=8ba7c3b63f87a443139c9104b02e3864dd31daf9..master

which means its not included in that daily build yet. It should be included in the next daily build.
Comment 20 Kevin Suo 2020-12-24 09:28:20 UTC
(In reply to Kevin Suo from comment #19)

As an alternative, you can use the dbgbuild:
https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/2020-12-23_20.50.11/

Which is based on 8652f3cd55e3baa40a28d0d50b710b9bde7acc04 and thus includes the patch. But this build is 701MB in size (since its a dbgutil build), so it may take some time to download.
Comment 21 Jambunathan K 2020-12-24 09:41:14 UTC
(In reply to Kevin Suo from comment #20)
> (In reply to Kevin Suo from comment #19)
> 
> As an alternative, you can use the dbgbuild:
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-
> dbg/2020-12-23_20.50.11/
> 
> Which is based on 8652f3cd55e3baa40a28d0d50b710b9bde7acc04 and thus includes
> the patch. But this build is 701MB in size (since its a dbgutil build), so
> it may take some time to download.

I will wait for your changes to hit the regular daily builds.  You will hear from in a day or two.
Comment 22 Jambunathan K 2020-12-31 07:26:21 UTC
(In reply to Jambunathan K from comment #21)
> (In reply to Kevin Suo from comment #20)
> > (In reply to Kevin Suo from comment #19)
> > 
> > As an alternative, you can use the dbgbuild:
> > https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-
> > dbg/2020-12-23_20.50.11/
> > 
> > Which is based on 8652f3cd55e3baa40a28d0d50b710b9bde7acc04 and thus includes
> > the patch. But this build is 701MB in size (since its a dbgutil build), so
> > it may take some time to download.
> 
> I will wait for your changes to hit the regular daily builds.  You will hear
> from in a day or two.

I installed master~2020-12-30_12.52.30_LibreOfficeDev_7.2.0.0.alpha0_Linux_x86-64_deb.tar.gz few minutes ago.

I am confirming that the issue is indeed fixed.
Comment 23 Jambunathan K 2020-12-31 07:30:55 UTC
Created attachment 168587 [details]
Ctrl + F2 now shows Close/Insert buttons
Comment 24 Kevin Suo 2020-12-31 08:20:19 UTC
(In reply to Jambunathan K from comment #23)
Thanks for confirming.
Comment 25 Commit Notification 2021-01-04 23:30:57 UTC
Kevin Suo committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/b6178d47ec1ec2cdd91727fe5fd792f6248d0222

tdf#130275: Fields dialog is too tall

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.