Bug 130340 - cmd + space = crashes reliably for keymap window
Summary: cmd + space = crashes reliably for keymap window
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1 target:6.3.5
Keywords: bibisected, bisected, regression
: 130452 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-01 08:29 UTC by gyrlgith
Modified: 2020-02-20 15:43 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gyrlgith 2020-02-01 08:29:55 UTC
tools> customize> keyboard
if you touch keyboard key cmd = os icon and space key, for shortcut keys area.
you can crashes libreoffice calc. also maybe, other libre software.

Operating System: Kubuntu 19.04
KDE Plasma Version: 5.16.5
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.2
Comment 1 Roman Kuznetsov 2020-02-01 23:17:54 UTC
PLease write here info from Help-About dialog

I can't repro it in

Версия: 7.0.0.0.alpha0+ (x64)
ID сборки: e8ac78d3afdeb0302eaea34a50f1ca912d5fe897
Потоков ЦП: 4; ОС:Windows 10.0 Build 17763; Отрисовка ИП: Skia/Vulkan; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded
Comment 2 gyrlgith 2020-02-02 07:51:50 UTC
Version: 6.3.4.2
Build ID: 1:6.3.4-0ubuntu0.19.04.1~lo1
CPU threads: 12; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: CL

I'm sorry. I will change to a test build of libre and try it out, but I do not know what will happen.
I will write it again if I try it.
Comment 3 QA Administrators 2020-02-03 03:30:55 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2020-02-04 16:03:48 UTC
Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: 447e4209fa16e765d9cba9f1c80bf10e8901204c
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2020-02-04 16:20:29 UTC
steps:
1. Open writer
2. Tools - Customize - keyboard
3- Click on Shortcut keys
4. Cmd + Space

-> Crash

Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3a42ee3284df7020ef111293a4d11148c1bf3a50

author	Caolán McNamara <caolanm@redhat.com>	2019-03-08 09:06:21 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-03-11 15:37:05 +0100
commit	3a42ee3284df7020ef111293a4d11148c1bf3a50 (patch)
tree	d12e7c85bb5e58c0ede3a500d56856e24a9ade0a
parent	231c06c5c2320c0465df0cbeab4c754937a05a9b (diff)
weld SvxConfigDialog

Bisected with: bibisect-linux64-6.3

Adding Cc: to Caolán McNamara
Comment 6 Caolán McNamara 2020-02-04 20:42:21 UTC
I suppose its Ctrl+Space, but I don't get a crash locally. Is there a bt ?
Comment 7 Xisco Faulí 2020-02-05 15:54:48 UTC
(In reply to Caolán McNamara from comment #6)
> I suppose its Ctrl+Space, but I don't get a crash locally. Is there a bt ?

The one next to the left Ctrl, usually with the windows logo
Comment 8 Xisco Faulí 2020-02-05 16:07:08 UTC
*** Bug 130452 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2020-02-05 16:08:30 UTC
(In reply to Caolán McNamara from comment #6)
> I suppose its Ctrl+Space, but I don't get a crash locally. Is there a bt ?

actually, it also crashes when pressing any number key ( 1, 2, 3, ...)
Comment 10 Caolán McNamara 2020-02-05 16:41:26 UTC
ah, it actually has to be something for which we *don't* have a match, bringing up the built-in gtk search box which means there is nothing selected and we crash on a null deref assuming something is selected
Comment 11 Commit Notification 2020-02-06 13:47:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/89f5d9efb74c9105b1bf7dc26ecd23e5cf711025

Resolves: tdf#130340 null deref when nothing selected

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2020-02-06 13:53:51 UTC
fixed in master, backport to 6-4 and 6-3 in gerrit
Comment 13 Commit Notification 2020-02-07 10:12:52 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5cbaec2ffd289f6b3e1dce15c00d5b1d3c2f815e

Resolves: tdf#130340 null deref when nothing selected

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-02-07 10:13:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/8f6c53c11ce9139fb2578332afa5783ec1a07a7f

Resolves: tdf#130340 null deref when nothing selected

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2020-02-07 17:24:31 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: c81c383be787ec5f9acbca51f75ea5b28b63c63a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 16 Commit Notification 2020-02-11 09:37:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/e4f7f537bd0be5dbb57790101dce263345d684f1

Resolves: tdf#130340 null deref when nothing selected

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-02-11 09:37:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-5":

https://git.libreoffice.org/core/commit/1a06c015d152d2af9c6f7c412657d0eac31ab94e

Resolves: tdf#130340 null deref when nothing selected

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 gyrlgith 2020-02-20 15:43:33 UTC
Operating System: openSUSE Tumbleweed 20200214
KDE Plasma Version: 5.18.0
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Kernel Version: 5.5.2-1-default
libre office 6.4.0.3
sorry for late. i checked for livre 6.4.0.3. this issue fixed. thanks for good job!