Download it now!
Bug 130343 - [Writer] Split height evenly between the selected rows
Summary: [Writer] Split height evenly between the selected rows
Status: RESOLVED DUPLICATE of bug 64242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-02-01 09:49 UTC by gmolleda
Modified: 2020-02-02 20:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Init, result and i want (14.61 KB, application/vnd.oasis.opendocument.text)
2020-02-02 18:22 UTC, gmolleda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmolleda 2020-02-01 09:49:17 UTC
Add new option in size of tables for split height evenly between the selected rows.

Steps:
1.- Create a new 6x4 table
2.- change the height of the last row to make it three or four times larger.
3.- selecting the last two rows, or all rows
4.- I need an option such that, when using it, calculate the total height of the selected rows and divide the height equally between the selected rows.

Obviously, if possible, because if the content of one of the rows needs more height, an error message may appear or leave that row higher even if the total is greater or subtract that height from the height to be distributed among the rest of the rows.

The problem was exposed in errors #64242 and #44871 but they were not errors, the current behavior was simply the one sought: to enlarge all the rows as much as the one with the highest height.

Español:
Añadir una nueva opción en el tamaño de las tablas para dividir la altura de manera uniforme entre las filas seleccionadas.

Pasos:
1.- Crea una nueva tabla de 6x4
2.- cambie la altura de la última fila para hacerla tres o cuatro veces más grande.
3.- seleccionando las dos últimas filas, o todas las filas
4.- Necesito una opción tal que, al usarla, calcule la altura total de las filas seleccionadas y divida la altura por igual entre las filas seleccionadas.

Obviamente, si es posible, porque si el contenido de una de las filas necesita más altura, puede aparecer un mensaje de error o dejar esa fila más alta incluso si el total es mayor o restar esa altura de la altura que se distribuirá entre el resto de las filas. .

El problema se expuso en los errores #64242 y #44871, pero no fueron errores, el comportamiento actual era simplemente el que se buscaba: agrandar todas las filas tanto como la que tenía la altura más alta.

Esperanto:
Aldonu novan eblon laŭ la grandeco de tabloj por dividi altecon inter la elektitaj vicoj.

Paŝoj:
1.- Kreu novan 6x4-tablon
2.- ŝanĝu la altecon de la lasta vico por fari ĝin tri aŭ kvaroble pli granda.
3.- Elektu la lastajn du vicojn, aŭ ĉiujn vicojn
4.- Mi bezonas opcion tia, ke, uzinte ĝin, kalkulu la tutan altecon de la elektitaj vicoj kaj ĝi dividas la altecon egale inter la elektitaj vicoj.

Evidente, se eblas, ĉar se la enhavo de unu el la vicoj bezonas pli da alteco, erara mesaĝo povas aperi aŭ lasi tiun vicon pli alta eĉ se la tuto estas pli granda aŭ ĝi povas subtrahi tiun altecon de la totala alteco por esti distribuita inter la ceteraj vicoj.

La problemo estis elmontrita per eraroj #64242 kaj #44871 sed ili ne estis eraroj, la nuna konduto simple estis la serĉata: pligrandigi ĉiujn vicojn tiel, kiel la plej alta.
Comment 1 V Stuart Foote 2020-02-02 17:10:37 UTC
Could you please be more precise, some screen clips would help, what is missing functionally?

Otherwise IMHO as implemented for bug 64242 vertical distribution of table rows already is provided, just a bit unclear from the "optimal" labeling.

Can be done by making a row selection. And from the <right mouse> context menu, or from the Table toolbar -> 'Optimize size' split button, select the 'Optimal row height' button action.

It will "distribute" the selected vertical height of the selected rows equally.

IMHO => WFM
Comment 2 gmolleda 2020-02-02 18:22:19 UTC
Created attachment 157602 [details]
Init, result and i want

The attach file have an example with I want and I get with diferent options.
Comment 3 V Stuart Foote 2020-02-02 19:59:55 UTC
Meta of your attachment shows you are on Linux with the 6.0.7.3 build.  This feature was implemented for the 6.2.0 builds by work on bug 64242.

Please update your LibreOffice installation.

On current 6.4.0.3 release build, and current master/7.0.0 this feature is fully functional.

*** This bug has been marked as a duplicate of bug 64242 ***
Comment 4 gmolleda 2020-02-02 20:23:08 UTC
Ok, perfect. Yes, I just have installed the new version and is perfect. Thanks.