Download it now!
Bug 130424 - Multiple selections cause huge CPU load and heavily delay UI markup
Summary: Multiple selections cause huge CPU load and heavily delay UI markup
Status: RESOLVED DUPLICATE of bug 121860
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2020-02-04 12:18 UTC by Frank Brütting
Modified: 2020-08-23 15:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example document (112.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-02-04 12:19 UTC, Frank Brütting
Details
Screen cast (1.65 MB, video/webm)
2020-02-04 12:21 UTC, Frank Brütting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Brütting 2020-02-04 12:18:47 UTC
Description:
When you hold down the Ctrl key and then select a few cell blocks with the mouse in my attached table, the UI gets delayed pretty quick and the CPU gets loaded pretty much. To my experience, every additional block causes exponential lags, so selecting 6 blocks causes way more load than selecting 5 blocks (guess this one additional block doubles the delay time).

I tested LibreOffice 6.3 and 6.4 on both Fedora 28 (X11) and Fedora 31 (Wayland).

I will attach a screen cast and that example document. That document basically is just a table I copied from a macro-generated XLSX document to this ODT file (and I applied some sort and color operation on it). With the empty default table, this is not reproducible.

Steps to Reproduce:
1. Open my attached table
2. Hold the Ctrl key and select a few block with the mouse

Actual Results:
After some selections, the UI gets delayed and there’s a heavy CPU load.

Expected Results:
These selections should not load or delay anything.


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
• LO options (LO ⇒ View) show that hardware acceleration and anti-aliasing is checked.
• When I check nothing or only check hardware acceleration, everything works fine.
• When I only check anti-aliasing, I experience slight lags.

• So the combination of these two options seem to cause this, I guess?



OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
Comment 1 Frank Brütting 2020-02-04 12:19:53 UTC
Created attachment 157637 [details]
Example document
Comment 2 Frank Brütting 2020-02-04 12:21:43 UTC
Created attachment 157638 [details]
Screen cast

At the beginning, I select 11 blocks, but you just see the first 3 of them. After loading the processor for 20 seconds, the remaining 8 block appear in the UI.
Comment 3 Roman Kuznetsov 2020-02-05 16:08:11 UTC
Frank, please write here info from Help-About dialog
Comment 4 Frank Brütting 2020-02-06 09:52:18 UTC
Version: 6.4.0.3
Build-ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU-Threads: 8; BS: Linux 4.19; UI-Render: Standard; VCL: gtk3; 
Flatpak
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded
Comment 5 Roman Kuznetsov 2020-04-26 00:18:29 UTC
no repro in

Version: 7.0.0.0.alpha0+
Build ID: 6c59c9d2b8818674640a50656ffba90f9cd3900e
CPU threads: 4; OS: Mac OS X 10.15.4; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

possible GTK3 only?
Comment 6 Caolán McNamara 2020-04-26 13:37:57 UTC
its probably an accessibility issue visible with gtks working accessibility support. attaching a debugger and getting a few backtrace samples would test that theory
Comment 7 Buovjaga 2020-08-23 15:18:57 UTC

*** This bug has been marked as a duplicate of bug 121860 ***