Download it now!
Bug 130440 - Undo in impress always switches back to first slide
Summary: Undo in impress always switches back to first slide
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1 target:6.3.6
Keywords: bibisected, bisected, regression
: 130488 130520 130539 130638 130957 131264 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-04 20:38 UTC by Kai
Modified: 2020-05-05 22:29 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai 2020-02-04 20:38:08 UTC
Description:
When pressing Ctrl+Z libre office successfully undos the last action but, for some reason, also switches from the current slide to the verify first slide of the presentation.

Steps to Reproduce:
1. Create a new presentation.
2. Make a second slide
3. Copy the second slide to make a third one
4. Insert some text into the second or third slide
5. Press Ctrl+Z

Actual Results:
Text is undone but the view switches back to slide 1.

Expected Results:
Text is undone but view stays the same


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Saving the document and restarting the application fixes it until I copy/paste another slide.
Comment 1 Leopoldo Saggin 2020-02-04 22:37:12 UTC
I have *exactly* the same behaviour using the same version of LibreOffice, ie 6.4.0.3. No idea of what happened in previos version because I never used Impress before. My OS is Win10 Pro 64 bit.
Anytime I try to use the "Undo" function to remove my last entry in a slide - whatever is the slide selected (for example n.100 in a series) - the view is switched to the first slide.
Very boring, especially if you have many slides and you have to scroll down to the 100th slide, for example :-(
Topoldo
Comment 2 raal 2020-02-05 01:48:21 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

7624b68638d636b960715a18027163794d32fefc is the first bad commit
commit 7624b68638d636b960715a18027163794d32fefc
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Dec 13 15:02:48 2019 +0100

    source sha:13dfaa3c3704a5a963f9e1e5d45796472f43c80e

author	Caolán McNamara <caolanm@redhat.com>	2019-12-13 12:47:54 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-12-13 14:35:29 +0100
commit	13dfaa3c3704a5a963f9e1e5d45796472f43c80e (patch)
tree	4b34fb8828934c21752f6e97537e18602dc9f4dc
parent	dcd3b5a52b343aa82933ba27be3396f46ee465ee (diff)
Resolves: tdf#129346 if nothing currently selected, select something
Comment 3 Xisco Faulí 2020-02-07 12:42:05 UTC
*** Bug 130488 has been marked as a duplicate of this bug. ***
Comment 4 Xisco Faulí 2020-02-10 11:06:12 UTC
*** Bug 130539 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2020-02-10 14:47:39 UTC
*** Bug 130520 has been marked as a duplicate of this bug. ***
Comment 6 Caolán McNamara 2020-02-10 19:49:38 UTC
fixed in master (hopefully) with https://cgit.freedesktop.org/libreoffice/core/commit/?id=50d9dbedc475069e1bb0b2788f814b8103c165c3 backports to 6-4 and 6-3 in gerrit
Comment 7 Commit Notification 2020-02-11 10:02:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/4abdcf7c73d16f6fee28dd0502f06a8385ebf019

tdf#130440 only select first page fallback if seting to current page failed

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-02-11 10:03:49 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/f12e4ecd595625f67865887824643c6608688ccc

tdf#130440 only select first page fallback if seting to current page failed

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-02-11 21:17:28 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ed602a3b8c0ffe922b4f082cd4cdaa5a8f0d64c

tdf#130440 only select first page if no other page is selected

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-02-12 09:01:17 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/718f540fb63af27c1336f89213444e9af753b8a9

tdf#130440: Add UItest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-02-12 10:50:34 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/e2aa8de67c3bf0cc09160b256c825fb586947ce6

tdf#130440 only select first page if no other page is selected

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-02-12 11:58:04 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/10dac1012b065e5e37ebb42f13d7fbdbda376786

tdf#130440 only select first page if no other page is selected

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 ian 2020-02-13 14:06:05 UTC
*** Bug 130638 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2020-02-16 22:07:10 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/6d1efc2b5dac95647b6e2c1ed7059e1964acf4fa

tdf#130440 only select first page fallback if seting to current page failed

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Lars Jødal 2020-02-19 11:48:11 UTC
(In reply to Commit Notification from comment #10)
> Xisco Fauli committed a patch related to this issue.
> It has been pushed to "master":
> 
> https://git.libreoffice.org/core/commit/
> 718f540fb63af27c1336f89213444e9af753b8a9
> 
> tdf#130440: Add UItest
> 
> It will be available in 7.0.0.
> 
> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Testing on LO 7.0.0.0.alpha0+, the bug is resolved.

Version: 7.0.0.0.alpha0+ (x64)
Build ID: cf96cb11e2a46c452a273ded1c66c556118983cf
CPU tråde: 4; Styresystem: Windows 10.0 Build 18362; Gengiver af brugergrænseflade: Standard; VCL: win; 
Lokalisering: da-DK (da_DK); Sprog for brugergrænseflade: da-DK
Calc: threaded
Comment 16 Xisco Faulí 2020-02-26 13:31:44 UTC
*** Bug 130957 has been marked as a duplicate of this bug. ***
Comment 17 Eyal Rozenberg 2020-02-26 20:45:32 UTC
Just seeing this myself. Super-annoying :-(

When is the next release due? I mean, 6.4.0.4 or 6.4.1 ?
Comment 18 Kai 2020-02-26 22:02:52 UTC
Imho you should push out a point release as soon as possible. This seems to be a major issue for a lot of people...
Comment 19 Lars Jødal 2020-02-27 18:02:15 UTC
Version 6.4.1 has today become available for download through the normal channels, and the bug is indeed fixed in that version :-)
Comment 20 Xisco Faulí 2020-03-19 11:57:54 UTC
*** Bug 131264 has been marked as a duplicate of this bug. ***