Bug 130462 - Form wizards have incorrect default size (win)
Summary: Form wizards have incorrect default size (win)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0 target:6.4.1
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-02-05 17:01 UTC by Xisco Faulí
Modified: 2020-02-19 17:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (14.46 KB, image/png)
2020-02-05 17:01 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-02-05 17:01:07 UTC
Created attachment 157676 [details]
screenshot

Steps to reproduce:
1. Open Writer
2. Form - Group Box

-> Wizard dialog has incorrect default size. See screenshot. Only windows

Reproduced in

Versión: 6.4.0.3 (x86)
Id. de compilación: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
Subprocs. CPU: 2; SO: Windows 6.1 Service Pack 1 Build 7601; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 1 Xisco Faulí 2020-02-05 17:02:24 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ba7ecfabfef579f27025603bceaac7c6a69e56cb

author	Caolán McNamara <caolanm@redhat.com>	2019-11-27 11:24:27 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-11-27 14:12:03 +0100
commit	ba7ecfabfef579f27025603bceaac7c6a69e56cb (patch)
tree	eb3a6985b124674d0c98a7bb3259130d6d4bff1d
parent	8012a200d1a7c5cd1b64a147ca6899fb8863ce8b (diff)
tdf#129042 set a min size for the wizard dialogs

Bisected with: bibisect-win64-6.5

Adding Cc: to Caolán McNamara
Comment 2 Caolán McNamara 2020-02-06 14:36:35 UTC
once its resized manually a little it snaps into the right internal layout
Comment 3 Caolán McNamara 2020-02-06 15:49:43 UTC
looks like for at least the windows backend SetMinOutputSize has to be before SetOutputSize
Comment 4 Commit Notification 2020-02-06 19:40:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f58074edfc7aa5b22475cd4b2aa2dd0729131fcf

tdf#130462 call SetMinOutputSizePixel before SetOutputSizePixel

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2020-02-06 19:43:10 UTC
that seems to work, fixed in master, backport to 6-4 in gerrit
Comment 6 Xisco Faulí 2020-02-07 18:40:22 UTC
Verified in

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 06164bdf2f5babd337a2f7813c572ca17056c521
CPU threads: 16; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

Caolán, thanks for fixing this issue!!
Comment 7 Commit Notification 2020-02-07 18:41:44 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c852f0e4ac4cee2a1b69ff8b1c5cab6633664098

tdf#130462 call SetMinOutputSizePixel before SetOutputSizePixel

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2020-02-19 13:12:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-1":

https://git.libreoffice.org/core/commit/be8a083cf11da380071e2f870f3a0bd5ab41715d

tdf#130462 call SetMinOutputSizePixel before SetOutputSizePixel

It will be available in 6.4.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.