Bug 130487 - PARAGRAPH DIALOG: Indent setting "Automatic" get's lost in a docx-file
Summary: PARAGRAPH DIALOG: Indent setting "Automatic" get's lost in a docx-file
Status: RESOLVED DUPLICATE of bug 58194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paragraph-Dialog DOCX-Paragraph Paragraph-Indent
  Show dependency treegraph
 
Reported: 2020-02-06 14:17 UTC by kevin
Modified: 2021-12-22 11:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Paragraph Formatting Test (18.85 KB, application/vnd.oasis.opendocument.text)
2020-02-06 19:18 UTC, kevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kevin 2020-02-06 14:17:03 UTC
Description:
The past several times I have established paragraph formatting on a document (specifically, automatic first line indentation), when I have saved and re-opened the file, that formatting has been gone. I'm saving as a docx file (Word 2007-2019). Everything else in the file saves correctly, but not the paragraph formatting.

Steps to Reproduce:
1. Set paragraph formatting (automatic first line indentation)
2. Save & close
3. Re-open file

Actual Results:
Formatting was not saved.

Expected Results:
Formatting should have been saved.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2020-02-06 18:40:37 UTC
Kevin, thank you for reporting the bug. Please attach a sample document (odt before saving as docx), as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 2 kevin 2020-02-06 19:18:43 UTC
Created attachment 157709 [details]
Paragraph Formatting Test

I created a new file and attached it. Saving it as an odt, I did not run into the same issue.
Comment 3 QA Administrators 2020-02-09 03:43:32 UTC Comment hidden (obsolete)
Comment 4 Dieter 2020-02-10 07:52:07 UTC
I confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: eeb2d19e77d6dc47c68e8ba0920a02cf64a1247b
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

and also with

Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Paragraph setting "Automatic" for indent get's lost

Steps to reproduce
1. Open an new document
2. Format =>Paragraph => Indents & Spacing
3. Set Indent to "Automatic" => OK
4. Save as docx and reopen

Result: Automatic is disabled.
Comment 5 Justin L 2021-09-17 14:15:33 UTC
This could only work if DOCX knew about automatic. However neither the Word UI, nor the documentation for w:hangingChars or w:firstLine have any provision for a non-specific value.

One could argue that LO should not just ignore the auto-indent completely on export, but should emulate this by specifying an comparable specific number. However, since this is very dependent on layout characteristics, it would be rather hard to do, and perhaps is best left for the user to specify.
Comment 6 Kevin Suo 2021-12-22 11:06:52 UTC

*** This bug has been marked as a duplicate of bug 58194 ***