Download it now!
Bug 130515 - Time field in Base form will not display correct format.
Summary: Time field in Base form will not display correct format.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.0.0 target:6.4.3 target:6.3....
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-02-07 20:13 UTC by Ken Gramm
Modified: 2020-03-11 12:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows simple database w/ one time field (19.67 KB, image/png)
2020-02-07 20:17 UTC, Ken Gramm
Details
Show sample data used for test (14.28 KB, image/png)
2020-02-07 20:18 UTC, Ken Gramm
Details
Shows current field format selected. (34.06 KB, image/png)
2020-02-07 20:19 UTC, Ken Gramm
Details
Shows incorrectly formatted data. (2.29 KB, image/png)
2020-02-07 20:19 UTC, Ken Gramm
Details
sample file (8.84 KB, application/vnd.oasis.opendocument.text)
2020-02-17 16:30 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Gramm 2020-02-07 20:13:13 UTC
Description:
I have a form in my Base DB and it will not display a 12 format.  I have edited the field and selected both the short and long 12h format and neither will display correctly.  Instead of a 12 format, I get the short 24h format.  But I can select the long 24 hour format and it will display correctly.

This field is being feed by a TIME field in the DB and this is a Firebird database.

I have had no issues editing the format of a date field or a large text field on this form.

This form is using the "In Blocks - Labels Above" arrangement, but I got the same results with the other arrangements too.

I can enter new times in either 12 or 24 format and both are accepted.

Steps to Reproduce:
1. Create a new DB with a time field.
2. Create a form to display/edit the field.
3. Edit the form field to display time in 12h format.
4. Try to display the data.

Actual Results:
I get the wrong format.

Expected Results:
Display the data in 12 hour format.



Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
This is a Fedora 31 machine, but I downloaded/installed LibreOffice directly from the internet.  I did not use the pre-packaged version.

Version: 6.4.0.3
Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded


One final note, I get the same results if I open this DB using a 6.3 or 6.4 version running on Windows.
Comment 1 Ken Gramm 2020-02-07 20:17:57 UTC
Created attachment 157734 [details]
Shows simple database w/ one time field
Comment 2 Ken Gramm 2020-02-07 20:18:33 UTC
Created attachment 157735 [details]
Show sample data used for test
Comment 3 Ken Gramm 2020-02-07 20:19:17 UTC
Created attachment 157736 [details]
Shows current field format selected.
Comment 4 Ken Gramm 2020-02-07 20:19:57 UTC
Created attachment 157737 [details]
Shows incorrectly formatted data.
Comment 5 Xisco Faulí 2020-02-17 16:30:54 UTC
Created attachment 157957 [details]
sample file

Not a base problem per se.
The problem is that changing the time format to HH:MM:SS PM doesn't work

Steps to reproduce:
1. open attached document

-> Time should be 12:12:00PM, instead, it's 12:12
Comment 6 Xisco Faulí 2020-02-17 16:32:34 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=65b7b6322b662785bf032e66c76abc36c9a2bb0e

author	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-08 10:40:28 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2017-02-08 12:42:52 +0000
commit	65b7b6322b662785bf032e66c76abc36c9a2bb0e (patch)
tree	762d3c233ac4a1d73dc67dd32183f1f4be9b2258
parent	20915bcbf45b4b0b4bc8c68c7df9eb6b13abbe06 (diff)
loplugin:unusedenumconstants read-only constants in vcl

Bisected with bibisect-linux-64-5.4

Adding Cc: to Noel Grandin
Comment 7 Commit Notification 2020-02-29 06:28:37 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9cb07cdca78e2cb1ecff84b7a8e154b23cc2a46d

tdf#130515 Time field in Base form will not display correct format

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-03-02 15:07:38 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 950e1aec0a984ce40a5038331f491272b51d41fa
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, thanks for fixing this issue!!
Comment 9 Commit Notification 2020-03-02 19:42:05 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/7a80d8b4c5379d2cbad02a16ddf82dae35821c52

tdf#130515 Time field in Base form will not display correct format

It will be available in 6.4.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-03-02 20:18:42 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/bccd604d1d1024943fb79377e7ff11d84e14760d

tdf#130515 Time field in Base form will not display correct format

It will be available in 6.3.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-03-05 08:52:30 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bef317ec9d00beb70d6b59c2af3b61ef2544b4a5

tdf#130515: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-03-11 12:58:28 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-4-2":

https://git.libreoffice.org/core/commit/589a9bc9401296a2ff28146b002a31c9d14455f2

tdf#130515 Time field in Base form will not display correct format

It will be available in 6.4.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.