Download it now!
Bug 130569 - TABLE can't edit a cell - word not shown
Summary: TABLE can't edit a cell - word not shown
Status: RESOLVED DUPLICATE of bug 128880
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2020-02-10 18:54 UTC by Jochen
Modified: 2020-03-10 22:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
file with the red cell that doesn't show the word (33.91 KB, application/vnd.oasis.opendocument.text)
2020-02-10 18:54 UTC, Jochen
Details
original word file (48.00 KB, application/msword)
2020-02-10 18:55 UTC, Jochen
Details
The document in current master (307.23 KB, image/png)
2020-03-10 22:42 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2020-02-10 18:54:20 UTC
Created attachment 157778 [details]
file with the red cell that doesn't show the word

Hi,
on the left, there is a red cell in the second row. The text "Rechtschreibung" can't read (not shown) and can't be edited -> Popup of "Content write protected". 

With the Version: 6.3.3 the cell could at least be read and edited. Now with the new version it is not possible anymore. 

It was a microsoft word file.
Comment 1 Jochen 2020-02-10 18:55:55 UTC
Created attachment 157779 [details]
original word file
Comment 2 raal 2020-02-10 22:16:08 UTC
This seems to have begun at the below commit.
Adding Cc: to XXX ; Could you possibly take a look at this one?
Thanks

02fc378262d92537ff213ef7002de3f3e78c9644 is the first bad commit
commit 02fc378262d92537ff213ef7002de3f3e78c9644
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Oct 30 04:00:08 2019 +0100

    source sha:435ab51ec8920033b7865f27f4afee8a852a0b31

author	Miklos Vajna <vmiklos@collabora.com>	2019-10-29 15:29:59 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2019-10-29 18:59:41 +0100
commit	435ab51ec8920033b7865f27f4afee8a852a0b31 (patch)
tree	c9c36ad076e7aef85cc78e3af399340d3998efc8
parent	c3877269eebc591578e1c6f7e19781b26774697b (diff)
tdf#128399 sw btlr: fix clicking to lower rotated cell
Comment 3 Gabor Kelemen 2020-03-10 22:42:59 UTC
Created attachment 158581 [details]
The document in current master

In a fresh master build this .doc looks as expected, the rotated text is visible and editable: 

Version: 7.0.0.0.alpha0+
Build ID: 1842276ed4785ff5198bdbc4ce6fe752315c8657
CPU threads: 16; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: hu-HU (hu_HU.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Gabor Kelemen 2020-03-10 22:44:11 UTC

*** This bug has been marked as a duplicate of bug 128880 ***