Bug 130576 - EDITING: The background of selected text remains after deselecting the text
Summary: EDITING: The background of selected text remains after deselecting the text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2020-02-11 00:27 UTC by Ayar
Modified: 2022-04-14 14:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The problem (562.35 KB, image/png)
2020-02-11 00:27 UTC, Ayar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ayar 2020-02-11 00:27:36 UTC
Created attachment 157782 [details]
The problem

Open new document
For any text of any length
Select an arbitrary text and then type any key deleting, therefore, that text and replacing it by that key's character
Do CTRL+Z
Maintain CTRL+SHIFT and press left arrow as to move the cursor one word to the left
The original background remains and a new one appears

In Ubuntu 18.04.3
Comment 1 Xisco Faulí 2020-02-11 12:54:57 UTC
Thank you for reporting the bug. To be certain the reported issue is not related to corruption in the user profile, could you please reset your Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the issue is still present
Comment 2 Ayar 2020-04-10 15:27:51 UTC
Hello Xisco,

I'm new to LibreOffice, so not sure if I did what you asked. I reset my Libreoffice profile by deleting the folder in /home/my_name/.config/libreoffice/4/user, I did a backup as suggested in https://wiki.documentfoundation.org/UserProfile

Im not in version 4 as the path suggests. In the meanwhile I installed libreoffice version 6.4.0.3 and the problem still remains...
Comment 3 Dieter 2020-04-13 13:59:53 UTC
Ayar, I'm not sure for 100% that I've grasp the problem, but I think I can confirm it with

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 962b415edb47187737a5f05c4ff3f6724a19c564
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-GB
Calc: threaded

Steps to reproduce

1. Open writer document or create a new one with some text
2. select a part of text and type a character (character replaces selected text)
3. CTRL+Z (previous selected text is back and is still selected)
4. CTRL+Shift and left cursor and mark some characters or a word
5. Click somewhere within the text

Actual result: Selection from step 4 disappears but selection from step 3 remains and it is not possible to deselct text

Expected result: No selected text.

Ayar, I hope this describes your bug. If not, please make a correction.
Comment 4 Ayar 2020-04-13 16:05:25 UTC
Dieter, that is exactly the bug I was trying to explain, I couldn't find it but I'm glad it's been already pointed out.
Comment 5 QA Administrators 2022-04-14 03:40:55 UTC Comment hidden (obsolete)
Comment 6 Dieter 2022-04-14 14:54:45 UTC
Can't reproduce with

Version: 7.3.2.2 (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

=> RESOLVED WORKSFORME