Bug 130603 - 'ñ' search return 'n' values too
Summary: 'ñ' search return 'n' values too
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2020-02-11 23:35 UTC by alejandrolibre
Modified: 2020-02-18 12:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alejandrolibre 2020-02-11 23:35:23 UTC
1) Ctr + F = Search

2) Search for 'ñ' into a file ( 'Spanish Document' in Options / Language Settings / Language of / Locale Setting )

3) It returns 'n' characters too.
Comment 1 V Stuart Foote 2020-02-12 08:32:02 UTC
Confirmed.

But by design. IIUC the search engine for the Find toolbar uses the ICU lib transformation to make search insensitive to diacritic markings (e.g. tilde, acute, caron, etc.) meaning the Find toolbar search will return both 'ene' and 'eñe' of Spanish scripts as they are treated as the same base for Unicode search.

This was a design decision to keep the <Ctrl>+F find bar lightweight, and applies equally to all scripts and locales.

The more robust 'Find & Replace' dialog provides the 'Diacritic-sensitive' checkbox. It is enabled by default for all locales, and the search with ICU libs does not combine the codepoints. Search for specific glyphs (U+00D1 LATIN CAPITAL LETTER N WITH TILDE), or (U+00F1 LATIN SMALL LETTER N WITH TILDE) succeeds.
Comment 2 Heiko Tietze 2020-02-18 12:19:38 UTC
Quick find bar is diacritic sensitive for me (only one ñ) and the search dialog (ctrl+H) allow both. Agree with Stuart on WFM.

Feel free to reopen if you think there is need to tweak the implementation (your use case is missing).