Bug 130632 - Customizable MsgBox text length
Summary: Customizable MsgBox text length
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-VBA
  Show dependency treegraph
 
Reported: 2020-02-13 08:50 UTC by Gerhard Schaber
Modified: 2020-06-16 15:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot for sample (4.80 KB, image/png)
2020-06-16 15:04 UTC, Gerhard Schaber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerhard Schaber 2020-02-13 08:50:31 UTC
This is a feature request. Could you make the text length per line in a MsgBox customizable? Currently it is wrapped at 80 characters.
Comment 2 Mike Kaganski 2020-06-16 12:55:35 UTC
MsgBox is a simple function for primitive message output, which is additionally compatible with VBA. It is not intended for complex task requiring such customizations. Anything non-default should be implemented using custom dialogs.

WONTFIX imo.
Comment 3 Gerhard Schaber 2020-06-16 13:14:02 UTC
An alternative would be for the msgbox to actually utilize the whole available area. The title of the box can be very long, and the dialog will be resized to a certain degree, but the contained text is truncated after a certain number of characters, no matter, if horizontally half of the box is empty
Comment 4 Buovjaga 2020-06-16 13:52:24 UTC
Yep, let's close
Comment 5 Gerhard Schaber 2020-06-16 15:04:18 UTC
Should I create a separate ticket for fixing the issue with lines being truncated too much?

Sub testmsgbox
msgbox "1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890", 1, "1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890"
End Sub

See attachment.
Comment 6 Gerhard Schaber 2020-06-16 15:04:48 UTC
Created attachment 162063 [details]
Screenshot for sample
Comment 7 Gerhard Schaber 2020-06-16 15:53:27 UTC
Correction, the lines are not truncated, but wrapped. In my opinion, if specifying the maximum length of the lines is not an option, lines should either not be wrapped at all (but rather have a scrollbar), or they should be wrapped at the right end of the available area. I would prefer the latter.