Download it now!
Bug 130637 - FILEOPEN: Table created in excel does not render correctly in Calc
Summary: FILEOPEN: Table created in excel does not render correctly in Calc
Status: RESOLVED DUPLICATE of bug 66377
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks:
 
Reported: 2020-02-13 12:51 UTC by Stephan Schutter
Modified: 2020-02-14 07:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
real life sheet (113.42 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-02-13 12:52 UTC, Stephan Schutter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Schutter 2020-02-13 12:51:35 UTC
Description:
When a table is formatted by "format as table", this table is not shown correctly in calc. Please see the attached real-life file. 

Steps to Reproduce:
1. In a new excel file create a table using the "format as table" option, fill in data. 
2. Save the document. 
3. Open the same document in Calc. Observe the table and not the rendering is missing borders and coloring. 

Actual Results:
Instead, the table is shown without colored lines and headers. Notably the width of hte columns appear to be incorrect as well. 

Expected Results:
the table should render the same as in excel.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
the table should render the same as in excel.
Comment 1 Stephan Schutter 2020-02-13 12:52:55 UTC
Created attachment 157837 [details]
real life sheet

Please review how the attached file looks and behaves in calc.
Comment 2 Xisco Faulí 2020-02-13 13:14:16 UTC
I believe you mean the table on the third sheet

Reproduced in

Version: 7.0.0.0.alpha0+
Build ID: f4b6f6a8ae60bdec53512728d00853b73fa18500
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2020-02-13 13:16:00 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 NISZ LibreOffice Team 2020-02-14 07:24:04 UTC

*** This bug has been marked as a duplicate of bug 66377 ***